[SOLVED] Yummed to Asterisk 11.11 tonight - Yikes!

Really weird problems after a Re-Boot - no Asterisk whatsoever and amportal was stuck in a loop - killed it with amportal kill which stopped the looping but Asterisk would not start - bombed very quickly and didn’t log any reason. I thought perhaps it was a corrupt install of the packages so I compiled 11.11 from scratch - same thing. Thought it might be the init script so I got one from another machine - still no. Finally compiled and installed 11.10.2 and then I can finally go to bed!

That is three hours of my life I will never get back - this is on the FreePBX Distro - 64 bit release version - yummed up to current and all FreePBX modules current - anyone else seen this? It’s awful!


It seems you hit two different issues (you created the second one): the very first after the reboot (this one should eventually be investigated but you provided no informations about your system/configurations/versions/logs) and the second after you forced a source package - think: Asterisk! - to build/install on a FreePBX Distro (a procedure that should be avoided, read here): never had any problem with FreePBX Distro (neither after reboots or upgrade from previous Tracks if it’s updated according to instructions. Maybe yuour one suffered of the lack of MySQL init fixer so after a dirty reboot it hanged?) but I always follow directions on how to manage it (not through YUM but through Update Scripts).

What a ridiculous reply - what is the point - you have NOTHING useful to add other than critiquing my troubleshooting technique - and you’re not even correct in your criticism.

When I run into a problem doing a NORMAL operation (and updating the box is certainly a normal operation!) and it totally breaks a production system, I try and post what I did to perhaps help others running into the same problem and through useful contributions from others, the problem is usually solved.

Usually the problem is user error (frequently mine) but sometimes it is a bad update being pushed either into a FreePBX module (search the archives - I have found many) or sometimes a bad package update (my suspicion in this case). Either way, the purpose of a community is to help others avoid the pitfalls that others have had to suffer through.

I was showing freepbx.org to a new customer we sold a system to last week - it’s a 40-Phone system and they were somewhat technical, but only on the Windows side of the house. I then showed them these forums and we looked at a sampling of the posts and responses, and then I had to explain to them that yes, there actually are many socially mal-adjusted people posting here and providing absolutely no useful information, only grief - you are certainly one of them.

Last night at 11:00 through a simple update, I took down our office system and there was no one to call but me - I am the helpline. After searching these forums to see if anyone else had experienced the problem, and not finding anything, I went about reading logs and solving the problem to get the system back functional when no one else was available.

I am sure that you would have been waiting to do it the “Right Way” and your system would have still been down in the morning, while I was back up and running by 1:30.


That’s probably a joke.

I really hope it’s a silly joke.

it’s unbelievable that you used such offending words (to me) when I wrote you only my consideration to your issues not to you as a person (issue that, IMHO, was very bad described…again you provided, up to now, still no details…speaking first about a mysterious “corrupt install of the packages”…no details…but this it’s up to you): so, in the end, you’re offending me on the public square when I’m not.

I’m not a software developer, I’m a community user…and so I see and look at things like a (more or less advanced) user, probably like you.

Ask yourself if any other FreePBX community user will ever understand what your issue was, what you exactly wrote, what components were involved and how exactly you solved…only complaints…I guess nobody will ever know and nobody will ever care about. Isn’t it?

Glad to read you solved fast. Have a nice nice day.

IMHO you didn’t shown us any “troubleshooting technique” here.

The issue is Asterisk 11.11 has a bug where Asterisk fails to start if their is no ooh323.conf file. We have reported the bug to Digium and supplied a patch. We will have new RPMs shortly.

For the time being doing a

touch /etc/asterisk/ooh323.conf

then restart asterisk will fix your issue.

That’s interesting @tonyclewis but, speaking form the point of view of FreePBX Distro users, at current level, only systems that have been forced to upgrade (to Asterisk 11.11) manually through yum (since there isn’t still any Upgrade Script that will provide Asterisk 11.11) may suffer this issue. Isn’t it?

Oh…but any Upgrade Script (also an old one or just the one used to migrate from Track 4 to Track 5) will pull the actual published Asterisk available through the freepbx.repo repository (and so the Asterisk 11.11)!

Basically FreePBX Distro users that force a system upgrade through yum are bypassing the necessary staging time/step useful to be (quite) sure that a FreePBX Distro Upgrade will end with a running system.

At this point, withdrawing that bugged Asterisk 11.11 (if not done yet) from freepbx.repo wouldn’t be safe?

The time it will take to pull back the RPMs versus us patch the RPM is the same. New RPMs will be pushed in the next hour.

1 Like

Thanks! That was very useful and hopefully if anyone else finds this post, there is the answer!


My issue was the title of the post - I yum updated to Asterisk 11.11 and then Asterisk wouldn’t load after a reboot. Seems pretty clear to me.

As to offending you or saying anything about you, your posts speak much more loudly than anything I could say.

In the future, all I ask is that if you don’t have something PRODUCTIVE to add to a post, then don’t. The signal to noise ratio is already way too low here - you are raising the noise level even higher.

Also notice how Tony knew exactly what I was talking about from my mysterious uninformative post - think maybe it’s you?


I doubt you exactly know what is a Signal to Noise ratio really…

Is it me? ask directly to Tony next time so you don’t pollute the Forum if you expect just one resolutive answer from a FreePBX Developer only (The CEO!).

new RPMs have been published. Patch has been submitted to Digium for them to include in 11.12 in the next week or so.

This topic is now closed. New replies are no longer allowed.
Marking this as solved and locking it up

It looks like some of the off topic replies intermingled with on topic replies may go in to a downward spiral so being mildly proactive here so we don’t get in to an unproductive flame war as we know both the problem and a solution.

You know I :heart_decoration: you all

If for some reason anyone feels this should be reopened feel free to flag this message for review