[SOLVED] Unable to update module

I am trying to update the modules and keep getting the same error on all of them…

Please wait while module actions are performed

Downloading and Installing framework
Downloading framework 4428098 of 4428098 (100%)
Error(s) downloading framework:
File Integrity failed for /var/www/html/admin/modules/_cache/framework-12.0.13.tgz.gpg - aborting (GPG Verify File check failed)

Anyone have a clue what is going on? this is happening with all the modules I try, everything I know and have read on here has not helped. To add to this, I thought maybe try a backup and I get an error telling me my backups are incompatible. What is going on??

No one have an idea what is going on? I can’t update the framework or anything, everything fails. The framework I have installed at this time is 12.0.11, I have cleared out the _cache directory and attempted several times.

This is nothing I have done, I have the paid module that automatically updates the system, I presume it was from this as everything has been updating without issue in the past.

As of right now, I have a hosed system that I can’t even reload a backup onto any longer.

If you have paid modules you might open a ticket.

I think ‘amportal a ma refresthsignatures’ may help.

Thanks Rob, I tried that, should have mentioned…

This is what I get, no matter what module or refresh I try.

[[email protected] ~]# amportal a ma refreshsignatures

Fetching FreePBX settings with gen_amp_conf.php…

Getting Data from Online Server…Done
Checking Signatures of Modules…
Checking accountcodepreserve…Signature Invalid
Refreshing accountcodepreserve
Downloading 4319 of 4319 (100%)
The following error(s) occured:

  • File Integrity failed for /var/www/html/admin/modules/_cache/accountcodepreserve-2.11.0.0.tgz.gpg - aborting (GPG Verify File check failed)
    [[email protected] ~]#

Hrm. There are two possibilities.

1: Someone is intercepting your internet connection and injecting bad things. This is unlikely.
2: Somehow your GPG settings are wrong.

Let’s assume option 2 is it.

[[email protected] tmp]# gpg --verify /var/www/html/admin/modules/_cache/accountcodepreserve-2.11.0.0.tgz.gpg
gpg: Signature made Tue 17 Jun 2014 07:20:47 AM AEST using RSA key ID 69D2EAD9
gpg: Good signature from “FreePBX Mirror 1 (Module Signing - 2014/2015) [email protected]
[[email protected] tmp]#

Note I’m doing that as root. All the GPG stuff is -not- done as the root user, it’s done as the asterisk user. If it works as root, then switch to the asterisk user, and try it then.

1 Like

That did not fix the issue, but it did lead me to find the issue…

I ran the GPG as you mentioned “in Asterisk user”, this gave me and error indicating the key was created 231487684 seconds in the future (time warp or clock problem). So I checked the time on my server and the time was set to january 6 2007 or something like that!.

I have no idea how the time on my server got changed, I am completely shocked to see the time was out that far. I am the only one with access to the server, it can’t be the battery as it is only 4 months old.

Anyway, I have now pointed the server to update its time every hour from another server I run, it is accurate to NIS time servers, so it should not go out. Now this has me thinking, the power went off the other night and the server did not come back online when the power restored… I need to check the bios to see what is going on.

Thank you for your help, the modules are now downloading correctly…

Dean

1 Like

hey,
How did you solve this issue??
when i enter the above mentioned command it shows me “gpg: Can’t check signature: public key not found”

and one line above it shows signature date and rsa key id.

The time was out on my server, go into your bios and check your time. Or you can set it from telnet but I can’t remember the command… I am not a Linux guru… sorry.

A ‘fwconsole chown’ (or ‘amportal chown’) should fix that error, and will tell you what the REAL error is. Also, make sure you’re doing it as the Asterisk user, not root.

The only user exist is the root. Do I need to create the “asterisk” for solving this problem or what?
when i type the command “amportal chown” its good bur when i type “amportal a ma refreshsignatures” it gives me error of"FIle integrity failed for modules…

Your machine needs an Asterisk user. I don’t know how it doesn’t have it. If your machine doesn’t have the asterisk user, then it’s quite possible that many many MANY other things are broken.

I’m actually somewhat impressed that you managed to get it to work this far without an asterisk user, we normally try really really hard to drop root privileges.

Whwn i tried to create “Asterisk” user it show me you already have one…
but when i tried to login it donot give me access.
There is not a single bit of memory in my brain that i had set password for asterisk user. Can you suggest me for its default password or way to change it?

login as root and then type

su asterisk

This works :slight_smile:
but now “amportal chown” and “amportal a ma refreshsignatures” is not working… :frowning:

Provide error messages PLEASE

but now “amportal chown” and “amportal a ma refreshsignatures” is not working

command not found

You should switch back to the root user.