[SOLVED]Unable to boot from CD, "Disk boot failure. Insert system disk and press enter."

Hello. I downloaded FreePBX-1.817.210.58-i386-Full-1350431735.iso from here, checked its md5 and burned it to a CD using imgBurn software. I changed the BIOS settings so that the first boot device is the CD-ROM and tried to boot from my freshly burned disk, but all I got was a “Disk boot failure. Insert system disk and press enter.” message.

Before posting here I made sure:

  1. That the CD was burned correctly by booting from it from a different PC. It worked flawlessly.
  2. That the CD-ROM drive on the PC I am trying to install FreePBX to works correctly by booting from an Ubuntu 12.04 Live CD. It booted without any problem.

The hardware may be kinda old. Is there something different between booting from an Ubuntu LiveCD and from a CentOS/FreePBX one? Should I ask at CentOS forum instead? Thank you in advance.

The md5sum of the cd must match the md5sum of the image

md5sum /dev/cdrom

Marginal hardware and marginal cd’s might give you that error, that check might show up such a problem.

Thanks for the advice! I checked the cd and it was OK, same as the iso and the md5sum posted here: http://www.schmoozecom.com/distro-download.php
What else can it be…?

It was the cd-drive’s fault, I changed it and it worked