(SOLVED) Trying to Update to 2.7: Possible Bug?

First of all am running AsteriskNow 1.5 with updated Asterisk x86_64 on a Dell PowerEdge1950 with 2.0Ghz Dual Quad-cores w/ 8gb ram.

Anyways, after I search for updates and try to update to 2.7 I get this error:

Error(s) installing versionupgrade:
A FreePBX version below 2.6.0alpha1 is required, you have 2.6.0

And brings me back to download 2.6 Upgrade Tool again? I have already downloaded and installed 2.6.0 and I try to do what it tells me to anyways and recieve this:

Errors with selection:

2.6 Upgrade Tool cannot be installed:
A FreePBX version below 2.6.0alpha1 is required, you have 2.6.0
Please try again after the dependencies have been installed.
No actions to perform.

Would really like to use the new fax feature (since Digium finally released a 64-bit version of there FFA) for freepbx that was integrated into 2.7 but how can I update my FreePBX box, since I have never updated to 2.6.0alpha1?

Anyone else having this odd error while trying to update?

Any suggestions on how I may fix this and beable to update to 2.7?

Any help will be greatly appreciated,
Thanks in advance,

You are trying to use the “2.6 Upgrade Tool”

This must have already been on your system and you must be trying to re-enable it.

You need to download and install the “2.7 Upgrade Tool” in order to upgrade from 2.6 to 2.7.

There should not be any bugs in it or we would have heard a lot of noise by now. We’ve had well over 2000 people upgrade with it… So check for updates again and make sure you download the “2.7” tool.

how are you getting the upgrade tool?

Did you manually install it (in which case you installed the wrong one) or did you go to the online repository and download it? (In which case you’ve got me baffled how that could happen)?

I have upgraded from the Module Admin within the FreePBX web-gui, then clicked on Check for Updates.

This is how I have received all of my updates for FreePBX, is this wrong?

Thanks for your quick response in trying to help.

Let me try to be more specific in what is exactly happening here:

Well this wont work, it comes up as an option to install the 2.7 upgrade tool,
but when I go to install it (select the tool, choose install, then click process) it gives me this:

Module Administration

Please confirm the following actions: (THIS MAY BE THE PROBLEM - Upgrade Tool

2.7 Upgrade Tool will be installed and enabled

I click confirm

Followed by this message:

Please wait while module actions are performed

Error(s) installing versionupgrade:
A FreePBX version below 2.6.0alpha1 is required, you have 2.6.0

Well by this message its saying that I can only update to 2.7 if I have below version 2.6?

So we can’t update from 2.6 to 2.7 ? That’s what the message seems to be. Seems that I need to be-able to upgrade to first, but how? I don’t get an option to.

Shouldn’t I get this option to upgrade to before being asked to upgrade to 2.7?


It’s not worth trying to debug what is happening or how you got in this situation.

Just go uninstall it if it is installed for some reason (sounds like not…).

Then go delete the module from your disk, e.g.:

rm -rf /var/www/html/admin/modules/versionupgrade

Then go and bring yourself up-to-date which will include re-downloading it and go through the upgrade.

Thanks that was what I was looking for a fix.

Well that worked now I am up to 2.7.


Now let me see if I can get some help with the Digium FFA.