[SOLVED] Recording Calls in FreePBX 2.5 doesn't do anything

Under Call Recording under General Settings, I have Extension Recording Override Disabled.
For my extension, i have both inbound and outbound calling set to always.

In my extensions_additional, MIXMON_FORMAT, MIXMON_DIR, and MIXMON_POST have been set by FreePBX.

When I call someone, nothing is recorded, and my script isn’t called.

When calling someone, I see this in asterisk:

– Executing [918569041300@tmm:3] Macro(“SIP/1121-0820de68”, “record-enable|1121|OUT|”) in new stack
– Executing [s@macro-record-enable:1] MacroExit(“SIP/1121-0820de68”, “”) in new stack

Looking up record-enable in my extensions_additional.conf, here is what I have:
[macro-record-enable]
include => macro-record-enable-custom
exten => s,1,MacroExit()

; end of [macro-record-enable]

from what I can tell, there is no macro-record-enable-custom. What does macro-record-enable do exactly? I apologize if I’m missing something here.

Asterisk: 1.4.18.1
FreePBX Core: 2.5.1.3

Found the answer. In my current version, “Extension Recording Override” is described as disabling recording. It actually does the opposite. I went back and Enabled it, which fixed my problem.

Hi Joe_CoT,

It was found and fixed. http://www.freepbx.org/trac/ticket/3426