[SOLVED] PJSIP error after Conversion from FPBX13 to SNG7-PBX-64bit-2002

Downloaded the ISO for SNG7-PBX-64bit-2002, installed into ESXi, all went well. Completed the usual network twiddling, updated CENTOS using YUM, and updated FPBX using the Module Admin. Then came configuration.

I used the converter to copy my FPBX-13 configuration to FPBX-15, as documented in " [Elastix and PBXinaFlash to FreePBX Distro Conversion Tool]. That ran without error. So far, so good.

Then I tried to connect to my VOIP provided (voip.ms). Much much pain, configuring and reconfiguring the connection string was to no avail. Finally I gave up, deleted the Trunk, and added it back in again.

My FPBX-13 connects using CHAN-SIP (usually - the connection has gotten a bit more difficult suddenly, after 2+ years). After the conversion I changed that to PJSIP but he configuration screens still most showed CHANSIP parameters (SIP incoming and outgoing parameters, connection strings, etc). I saw different screen and parameters after I deleted and re-added the Trunk, than I initially did after conversion.

Anyway, delete and re-add worked. Everything registered right away. Either something in the converter didn’t copy the trunk across correctly, or I fat-fingered something, or the conversion left some legacy that confused the GUI when I tried to change from CHANSIP to PJSIP.

BTW, connection using CHANSIP was impossible - I was getting DNS resolution errors and who knows what else.

NOT TESTED: Deleting the CHANSIP trunk, and then re-adding it as CHANSIP.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.