[SOLVED] Outbound Dial randomly Fails -- Twilio -- Suggestions?

Hello, We are having a situation where our outbound dial randomly fails (timeouts). We are using Twilio Elastix SIP for our trunks. We did not have this issue until we brought on our second and third twilio trunks online (2 more PBX servers).

I have done a pcap on one of the affected servers and it’s upline firewall and also a debug on the SIP itself. Our PBXs show they are calling, but no packet is ever actually sent out. The pcap on the server and the pcap on the firewall show nothing for connections attempted out. The system will eventually give a timeout message.

After some time, and dialing or not dialing a 1 (who knows if this matters) it will eventually dial out and connect the call. It will then stay working for a little while and then quit.

At first we thought it may be UDP related, but we are using “Secured SIP” with these trunks (TCP/TLS over Port 5061).

Any suggestions on what to look for/into would be great. As a test, I fresh installed a totally vanilla server and it exhibited the same behavior.

Also, one server is behind a SonicWall SOHO and the other is behind a Meraki MX65.

For anybody that comes across this post and is looking for a solution, here is what we found.

  • This issue was only related to TLS outbound trunk connections for CHAN_SIP.
  • The issue didn’t always occur on Vanilla installs… but did sometimes
  • The issue definitely occurred after upgrading the core of FreePBX (distro upgrade)

It turns out this was actually related to the Phone Servers being virtualized. We are running them on VM Ware eSXi 6.0u3 on Dell PowerEdge R710 servers. It has something to do with the network card and how it is passing data. We are currently using the VMXNET3 Virutal Cards. It’s possible that switching to the tried and true E100 would have also fixed this issue or even doing direct SRV-IOV Pass through… however we do not think we will need to.

The VM Ware tools needed installed/reinstalled after upgrading the Phone Server to the newest stable distro version. Once we did this, we have had rock solid connections. We were tipped off by a comment in this article from Renrick McDonald (http://www.asteriskguru.com/tutorials/peer_is_now_unreachable.html) that indicated similar issues when using VirtualBox but not when using Hardware install.

We followed this post to install the VM Ware tools on FreePBX

We followed this article for distro upgrades to upgrade the phone servers that we don’t pay for System Admin on:

Also we found that after making all of the updates, the system received a new MAC Address. We followed this article to change the Eth1 back to Eth0 which had all of our static info on it. Alternatively we could have just change the VM to static the old MAC Address and this would have also fixed the issue.