Solved - Issue with the last core/framework upgrade (


Some issue with this upgrade on FreePBX 14 :

core (current:
framework (current:

  • Some feature codes like “In-Call Asterisk Disconnect Code” not in the list anymore
  • typing ‘*’ hangup the call

many more call drops (but maybe not related)

After rollback to version and back to normal.


We have removed “In-Call Asterisk Disconnect Code”.

I have tested a few machines and dialed different numbers and hit “*” and “*2” and “*1” and the call never disconnects.

Hi, i’ve the same problem.
Same version and same problem (when i press ‘*’ the call hang up immedialty)
How i can rollback to old version?

I call my mobile phone

 == Spawn extension (from-sip-external, 3295913899, 1) exited non-zero on 'SIP/Estracom-000007d8'
    -- SIP/Estracom-000007d8 Internal Gosub(func-apply-sipheaders,s,1) complete GOSUB_RETVAL=
    -- Called SIP/Estracom/3295913899
       > 0x7f96f84c8ef0 -- Strict RTP learning after remote address set to:
    -- SIP/Estracom-000007d8 is making progress passing it to SIP/6005-000007d7
       > 0x7f96f84c8ef0 -- Strict RTP switching to RTP target address as source
    -- SIP/Estracom-000007d8 is ringing
       > 0x7f9700aa6b50 -- Strict RTP switching to RTP target address as source
       > 0x7f9700aa6b50 -- Strict RTP learning complete - Locking on source address
       > 0x7f96f84c8ef0 -- Strict RTP learning complete - Locking on source address
    -- SIP/Estracom-000007d8 answered SIP/6005-000007d7
    -- Channel SIP/Estracom-000007d8 joined 'simple_bridge' basic-bridge <b7fbbd63-ba83-4267-9438-a8db738b454f>
    -- Channel SIP/6005-000007d7 joined 'simple_bridge' basic-bridge <b7fbbd63-ba83-4267-9438-a8db738b454f>

i press '*'

    -- Channel SIP/6005-000007d7 left 'simple_bridge' basic-bridge <b7fbbd63-ba83-4267-9438-a8db738b454f>
  == Spawn extension (macro-dialout-trunk, s, 31) exited non-zero on 'SIP/6005-000007d7' in macro 'dialout-trunk'
  == Spawn extension (from-internal, 3295913899, 6) exited non-zero on 'SIP/6005-000007d7'
    -- Executing [[email protected]:1] Macro("SIP/6005-000007d7", "hangupcall") in new stack
    -- Executing [[email protected]:1] GotoIf("SIP/6005-000007d7", "1?theend") in new stack

Ok, i’ve found and tried this with success

I’m getting hangup when dialing * during any calls (internal and external).

Also this is now fixed (eg reverted)

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.