[solved] Installation error on Armbian Stretch (Debian 9): 'sh: 1: runuserasterisk: not found'

Sorry if this is something obvious I’ve missed, but I dug around for a while and couldn’t see anyone getting this error similar to how its written out in the console.

I installed naf’s GVSIP fork of Asterisk on my Orange Pi Zero running Armbian Stretch as a fresh install. (I had to do things a bit differently than what was in the guide here by xekon & a few other places, so if I can ultimately get this working and anyone is curious, I’d be happy to share.)

When I go to install FreePBX I get these errors:

Checking if Asterisk is running and we can talk to it as the 'asterisk' user...sh: 1: runuserasterisk: not found
Error communicating with Asterisk.  Ensure that Asterisk is properly installed and running as the asterisk user
Asterisk appears to be running as asterisk
Try starting Asterisk with the './start_asterisk start' command in this directory

When I check my services with ps aux | grep asterisk, I can see that it is running as asterisk:

asterisk   667  0.0  0.6 229300  1644 ?        Sl   Jul22   0:01 /usr/sbin/apache2 -k start
asterisk   668  0.0  0.6 229300  1644 ?        Sl   Jul22   0:01 /usr/sbin/apache2 -k start
root      1836  0.0  0.1   1432   456 pts/0    S    Jul22   0:01 /bin/sh /usr/sbin/safe_asterisk -U asterisk -G asterisk
asterisk  9073  106  8.4  65180 20852 pts/0    Sl   00:23   0:02 /usr/sbin/asterisk -f -U asterisk -G asterisk -vvvg -c
root      9093  0.0  0.2   3764   516 pts/0    S+   00:23   0:00 grep asterisk

I haven’t been able to find any reference to “runuserasterisk: not found” on Google or in different forums. I was wondering if it had something to do with the configuration files, but I can’t see anywhere that it has runuserasterisk written out with no spaces. I also removed the runuser=asterisk part from asterisk.conf and tried again, but it made no difference whether it was there or not.

I also get these in Asterisk when I run with -cvvv in the console:

Asterisk Dynamic Loader Starting:
[Jul 23 00:10:06] WARNING[6319]: loader.c:1868 loader_config_init: 'modules.conf' invalid or missing.
[Jul 23 00:10:06] ERROR[6319]: asterisk.c:3920 check_init: Module initialization failed.  ASTERISK EXITING!

Since I haven’t installed FreePBX, I haven’t added any modules either, so I’m assuming that’s what these are related to?

If anyone could offer some insight I would really appreciate it!

Just wanted to update that I figured out what was up last night. I messed up the structure when I was forcing it to check the version differently than the default, so the output was grabbing the “runuser” from that line in the .php file. Changing it to check using -V allowed me to finish the install.

1 Like

As mentioned by @xekon already. The proper way to fix this is in Asterisk

cd /usr/src
sudo git clone https://github.com/naf419/asterisk.git --branch gvsip
cd asterisk
sudo sed -i 's/^MAINLINE_BRANCH=master/MAINLINE_BRANCH=15/' build_tools/make_version

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.