[SOLVED] Incoming Calls Issues

Hi,

I’ve gone from inbound calls dropping with goodbye message to calls with number not in service message, feels like progress but maybe not.

Can someone please help, yes I have searched, Google, these forums and tried various fixes to no avail.

My log is:

[2013-02-22 11:24:17] VERBOSE[14425] pbx.c: – Executing [[email protected]:3] Wait(“SIP/7Active-00000002”, “2”) in new stack
[2013-02-22 11:24:19] VERBOSE[14425] pbx.c: – Executing [[email protected]:4] Playback(“SIP/7Active-00000002”, “ss-noservice”) in new stack
[2013-02-22 11:24:19] VERBOSE[14425] file.c: – <SIP/7Active-00000002> Playing ‘ss-noservice.ulaw’ (language ‘en’)
[2013-02-22 11:24:22] VERBOSE[14425] pbx.c: == Spawn extension (from-pstn, s, 4) exited non-zero on ‘SIP/7Active-00000002’
[2013-02-22 11:24:22] VERBOSE[14425] pbx.c: – Executing [[email protected]:1] Macro(“SIP/7Active-00000002”, “hangupcall,”) in new stack
[2013-02-22 11:24:22] VERBOSE[14425] pbx.c: – Executing [[email protected]:1] GotoIf(“SIP/7Active-00000002”, “1?theend”) in new stack
[2013-02-22 11:24:22] VERBOSE[14425] pbx.c: – Goto (macro-hangupcall,s,3)
[2013-02-22 11:24:22] VERBOSE[14425] pbx.c: – Executing [[email protected]:3] ExecIf(“SIP/7Active-00000002”, “0?Set(CDR(recordingfile)=)”) in new stack
[2013-02-22 11:24:22] VERBOSE[14425] pbx.c: – Executing [[email protected]:4] Hangup(“SIP/7Active-00000002”, “”) in new stack
[2013-02-22 11:24:22] VERBOSE[14425] app_macro.c: == Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/7Active-00000002’ in macro ‘hangupcall’
[2013-02-22 11:24:22] VERBOSE[14425] pbx.c: == Spawn extension (from-pstn, h, 1) exited non-zero on ‘SIP/7Active-00000002’

Any help much appreciated.

For some reason the VOIP provider isn’t passing the DID, so calls weren’t routing by DID.

You need an inbound route.

And if necessaryL-

http://www.freepbx.org/support/documentation/howtos/how-to-get-the-did-of-a-sip-trunk-when-the-provider-doesnt-send-it-and-

ahaa! Brilliant, thanks for that link, exactly what I need.

As ever, actually reading the documentation is alway “a good thing”

I finally made some progress and able to place outbound calls
when incoming is dialed it just beeps like the handset is off hook to long.
I am currently outside my local network so i can not access log info like first post due to firewall settings.How do i view that log info? so i can get help on
inbound issues?
thanks

http://your.box/admin/config.php?display=javassh

just downloaded the latest version of java and enabled the plugin
try to access log file but get this

If necessary re-enter the maint user and password. Once the applet has opened enter the IP address of your PBX.
You will then connect to the FreePBX server. You can then login as ‘root’ or ‘asterisk’, or whatever user you have created.

Sorry, it’s your machine :slight_smile: if the java applet doesn’t open it’s your setup also.

Best thing is to fix your network/routers to allow your responsible hosts ssh access on something other than 22