[Solved] Incoming calls do not work


(Gmv) #1

Hi,

First of all I’m quite noob on telephony and very noob with Freepbx
I have installed a brand new FreePBX,

It’s connected to an OVH siptrunk and appear Online.
I have right now only one extension confgured.

Outgoing calls works.
Incoming calls not really works.

In inbound rules if I redirect any calls to my extension 5555, I receive calls on my extension.
But If I configure specific SDA (0987654321) in DID for inbound routes, I have a message like : “the number you have dialedis not in service”

This is what I have with tcpdump (line numbers changed on purpose) :

Call-ID: 12189-NY-c5af290a-251fbced6@siptrunk.ovh.net 
CSeq: 1651258581 BYE 
From: "+33688448217" <sip:0123456789@siptrunk.ovh.net;user=phone>;tag=12189-QK-c5af290b-78bfaeaf0 
Max-Forwards: 29 
Record-Route: <sip:91.121.129.23:5060;lr>;session=335690 
To: <sip:0987654321@10.7.1.163;user=phone>;tag=e5a8fb35-b51b-4679-8afc-98615b0495f7 
Via: SIP/2.0/UDP 91.121.129.23:5060;branch=z9hG4bK-NFWT-3f10314e-681fd68c 
Reason: q.850;cause=16 
User-Agent: Cirpack/v4.76 (gw_sip) 
Content-Length: 0 

In Asterisk Logs This is what I have :

[2020-05-09 13:42:25] VERBOSE[21595] pbx_variables.c: Setting global variable 'SIPDOMAIN' to '159.180.228.59'
[2020-05-09 13:42:25] VERBOSE[30596][C-000007a7] pbx.c: Executing [s@from-pstn:1] NoOp("PJSIP/OVH-Trunk_Seconde-000007cc", "No DID or CID Match") in new stack
[2020-05-09 13:42:25] VERBOSE[30596][C-000007a7] pbx.c: Executing [s@from-pstn:2] Answer("PJSIP/OVH-Trunk_Seconde-000007cc", "") in new stack
[2020-05-09 13:42:25] WARNING[30596][C-000007a7] chan_sip.c: This function can only be used on SIP channels.
[2020-05-09 13:42:25] VERBOSE[30596][C-000007a7] pbx.c: Executing [s@from-pstn:3] Log("PJSIP/OVH-Trunk_Seconde-000007cc", "WARNING,Friendly Scanner from ") in new stack
[2020-05-09 13:42:25] WARNING[30596][C-000007a7] Ext. s: Friendly Scanner from
[2020-05-09 13:42:25] VERBOSE[30596][C-000007a7] pbx.c: Executing [s@from-pstn:4] Wait("PJSIP/OVH-Trunk_Seconde-000007cc", "2") in new stack
[2020-05-09 13:42:27] VERBOSE[30596][C-000007a7] pbx.c: Executing [s@from-pstn:5] Playback("PJSIP/OVH-Trunk_Seconde-000007cc", "ss-noservice") in new stack
[2020-05-09 13:42:27] VERBOSE[30596][C-000007a7] file.c: <PJSIP/OVH-Trunk_Seconde-000007cc> Playing 'ss-noservice.alaw' (language 'en')

Thanks by advance to any help.

B.


(Lorne Gaetz) #2

Looking at the info provided (good job!) we can see your provider does not include the DID in the invite, but does (or appears to) put it in the To header. Change the trunk context to from-pstn-toheader to fix.


(Gmv) #3

Great !!

I’m struggling with this for hours now. And it takes you 5 minutes to give me answer!

Many thanks.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.