[SOLVED] How to setup a Gamma PJSIP trunk

I have got my FreePBX 14 system installed and received my IP details from Gamma, but I am struggling to setup the PJSIP trunk. This is the first time I have used FreePBX so sorry if I am just being stupid.

So far all I have is the Gamma IP in ‘SIP server IP’, port 5060 in SIP server port, and set authentication to none as Gamma uses IP authentication. With these settings I can receive calls but cannot make calls.

Any help would be appreciated.


I know nothing about Gamma but in general, this is easy to debug. At the Asterisk command prompt, do
pjsip set logger on
then attempt an outgoing call. Your outbound INVITE will appear in the Asterisk log, as well as any reply.

If there is a reply (403, 404, 503, etc.) that should be a clue as to what is wrong. There may also be a Warning or other header in the reply with additional information about the error.

If there is no reply at all, check that you have correctly set your external IP address in your list of authorized addresses in the Gamma portal. Also check that the Via header in your INVITE contains your external IP address (if not and your PBX is behind a NAT, check that the NAT settings in Asterisk SIP settings are correct and restart Asterisk if you change them).

I am running the asterisk rvv and I can see that my global variable 'SIPDOMAIN' is set to my internal IP and not my External NAT address. I have set General SIP Settings external ip, I have set Chan PJSIP settings External IP, but none of these seem to be making a change.

Okay, so after talking with Gamma, it seems that my only issue is with my NAT settings. It is passing my internal IP and that won’t authenticate.

I have manually set my external IP everywhere that I can find but still no luck.

Okay, I have got it all sorted now. PJSIP doesn;t play nice with External Addresses and NAT.

I had to remove the external address from General SIP Settings

Set Domain the transport comes from to my external ip in Chan PJSIP Settings.

and now I can make and receive phone calls.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.