[Solved] How to reinstall "core" module?

Hi FPBX Community,

I just updated some modules and now I am receiving an error.


Reload failed because retrieve_conf encountered an error: 255



I cannot access SIPSTATION

   exit: 255
   PHP Fatal error:  Uncaught exception 'Exception' with message 'Unable to locate the FreePBX BMO Class 'Core'A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install core 2) fwconsole ma enable core' in /var/www/html/admin/libraries/BMO/Self_Helper.class.php:216

Stack trace:

   #0 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(104): FreePBX\Self_Helper->loadObject('Core')
   #1 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(37): FreePBX\Self_Helper->autoLoad('Core')
   #2 /var/www/html/admin/modules/webrtc/Webrtc.class.php(46): FreePBX\Self_Helper->__get('Core')
   #3 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(125): FreePBX\modules\Webrtc->        >        >__construct(Object(FreePBX))
   #4 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(37): FreePBX\Self_Helper->autoLoad('Webrtc')
   #5 /var/www/html/admin/libraries/BMO/Hooks.class.php(198): FreePBX\Self_Helper->__get('Webrtc')
   #6 /var/www/html/admin/libraries/BMO/Hooks.class.php(38): FreePBX\Hooks->preloadBMOModules in >        /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 216

I ran…

fwconsole ma install core

Then I got the following error

exit: 255
found language dir en_UK for broadcast, not installed on system, skipping
found language dir fr for directory, not installed on system, skipping
found language dir en_UK for pagingpro, not installed on system, skipping
PHP Fatal error: Call to undefined function core_devices_list() in /var/www/html/admin/modules/digium_phones/classes/digium_phones.php on line 102

Here is Line 102

    public function cache_core_devices_list() {
            foreach(core_devices_list('all', 'full') as $device) {
                    $this->core_devices[$device['id']] = $device;

The Module Named “core” is required, but yours is broken. You should reinstall it and try again.

I tried to reinstall it via the module admin but then I got the following…

Please wait while module actions are performed

Installing core
Error(s) installing core:
Module is broken and cannot be installed. You should try to download it again.

Is this a distro machine?

I apologize but what do you mean by distro machine?

Fyi my machine is an old Dell desktop computer which has latest FPBX the latest non beta version.

I see you commented here:

Should I try to remove a conf file.

You are very confused. Firstly that ticket has nothing to do with this issue. Secondly you are running alpha software but you are telling me it’s not beta. Alpha is worse than beta. I also have no idea how you installed freepbx.

Yes sir, I am very confused. Thank you for continuing to interact with me. :smiley:

Allow me to coherently explain the process at which my machine met it’s demise.

Okay so, picture this - I have a Dell Optiplex 745 with 8GB of RAM. Which I figure could easily have 3 Polycom IP Phones connected to it.

So, then I burned the FreePBX 64 bit 10.13.66 on a Dual Layer Memorex 8.5 GB DVD.

I successfully installed the distro, setup the network configurations, configured SIPSTATION, and had just finished provisioning a Polycom IP Phone via Endpoint Manager.

Then, I proceeded to the Dashboard to check if the user was online but then my A.D.D. kicked in and I noticed modules needed updated. So, I went over to the Admin Module. Then… this post happened.

Alpha is worse than beta.


In software development, a beta test is the second phase of software testing in which a sampling of the intended audience tries the product out. (Beta is the second letter of the Greek alphabet.) Originally, the term alpha test meant the first phase of testing in a software development process.

Damn… well then I will lick my wounds, and proceed to install Alpha on the machine. Unless, you have another suggestion.

That is not a stable release. It’s alpha.

It doesnt seem like you actually installed core. Go to module admin. Uninstall core and then check online and reinstall it.

The Distro version you have downloaded is Alpha, not really suitable for beginners or production. You want the current Stable version:

Okay, well I’ll go ahead and document it anyways. Uninstalling the core will not happen in the GUI.

Screenshot 1

Screenshot 2

Screenshot 3

Screenshot 4

Screenshot 5

as I did with my system when errors’ 'PHP Fatal error: Call to undefined function core_devices_list () in /var/www/html/admin/modules/digium_phones/classes/digium_phones.php on line 102’
Module I upgrade to version 12.0.4 Core to 12.0.39 shall have all these errors.
I did not know you can help correct.