[SOLVED] Google Voice [Motif] Asterisk 11.3 : Does not connect calls

Hi all,

I am (still) testing the latest distro but result in having no working google voice calls. It rings, does not seem to connect really, and keeps ringing until it cuts.

This test is being performed in parallel to an existing production FreePBX server. The machine used for the test is a virtualbox machine, clones from the production machine (Asterisk 1.8 with freepbx 2.11), on which I took care to change the mac address not to have duplicate mac adress in the same subnet.
then I loaded the FreePBX iso and reformated the whole disk with this lastest version: the 32bit FreePbx 2.11 with Asterisk 11.2 ( Build 63-8) and upgraded to 11.3 with yum.
I then loaded with the Back-up module the PBX config of the production server (With Asterisk 1.8)
The production server having chan_mobile and google voice I configured the chan_mobiles by hand. And the google voice by the new Motif module.
In the production server Google voice was with Google talk, configured in jabber.conf and a gtalk.conf, but configuring it in the new asterisk 11 went very fast, and it reported “Connected” instantly. But “Connected” is obviously not enough.
Using a phone connected to the production system, calls in google voice work perfectly. Using a phone connected to the test system on ASterisk 11.3, a google voice call rings and seem to never connect. Then disconect alone after about 30 secs.

The log with RTP debug activated gives the following :
21:36:34] VERBOSE[3830][C-] pbx.c: – Executing [[email protected]:30] Dial(“SIP/203-00000019”, “Motif/ggtalkvehiculosvipcom/[email protected],300,r”) in new stack
21:36:34] VERBOSE[3831][C-] app_mixmonitor.c: == Begin MixMonitor Recording SIP/203-00000019
21:36:34] VERBOSE[3830][C-] app_dial.c: – Called Motif/ggtalkvehiculosvipcom/[email protected]
21:36:35] VERBOSE[3830][C-] app_dial.c: – Motif/[email protected] is proceeding passing it to SIP/203-00000019
21:37:08] VERBOSE[3830][C-] app_dial.c: – Motif/[email protected] answered SIP/203-00000019
21:37:08] VERBOSE[3830][C-] pbx.c: – Executing [[email protected]:1] Macro(“SIP/203-00000019”, “hangupcall,”) in new stack

2 Things :
First their is no RTP going out or in…
Second, the call seems to go through as it rings in the extension but as soon as the message “answered” appears the comuncation is cut.

I could not find on internet the list of ports required for RTP for the new google voice [motif] module, does any body know what it is ?
Is there a was to get more logs of the [motif] channel ?
Any other idea ?

In another post you mentioned that the 10 digit number isn’t connected to your google account. If that is true then you’ll never get the module to work the way you want it to. In it’s current state you need to have a valid google talk telephone number.

Ok , but in the new distro jabber.so and gtalk are not compiled… so I have no way to have Google voice working on the lastest distro like I have it in the Asterisk 1.8 ?

I managed to simulate an US IP adress.
I now have my Google Voice 10 digit.
I have put it in the Google Voice [Motif] Field and everything is the same…
A little worse I would say as now it keeps ringing endlessly, and the call never gets actually conected. I’ll post the logs in another post.
Still no idea anybody pleaaaase…
I dont want to have to compile my own asterisk to add jabber and gtalk modules…

Google knows who you really are IP wise, they won’t play with you if you are not in the US.

So problem solved.
Many thanks tm100 for your help !
But the [Motif] module would gain a lot by not having to input the 10 digit number… especially for non US users.
Cheers !

no doubt about that :wink:

Well gtalk and jabber are depreciated in Asterisk 11. You’d want res_xmpp and chan_motif. Which is what you’ve been talking about since day one, but then you kept referencing gtalk and jabber!