[SOLVED] FreePBX 15 Warm Spare Backup cannot authorize access to document


(HawkEye) #1

Hello,
Warm Spare backup with FreePBX 15 displays message …

This server could not verify that you
are authorized to access the document
requested.

Followed the wiki from: https://wiki.freepbx.org/pages/viewpage.action?pageId=185631299

Can ssh from primary to backup server without password using ssh -i /home/asterisk/.ssh/id_rsa root@SecondaryServerIP
Copied credentials from API on warm server to Primary server backup settings… When clicking ‘Get Warm Spare Token’ it displays same error

This server could not verify that you…

Disabled iptables to make sure the firewall was not blocking it.

Any help is appreciated.
Thanks.


(Sergio Lobera) #2

Hi ! Try this:
Go to your Warm Spare server (CLI) and type this:

chmod 600 /etc/asterisk/keys/api_oauth_public.key

Then try again


(HawkEye) #3

Hi Sergio, tried it and it did not resolve the issue of authorization.


(HawkEye) #4

The automated warm spare backup displayed the following in the failure mail:

[2020-Jun-30 00:20:45] [31e45079-ea35-4159-9925-40a78e271328.ERROR]: The requested driver seems invalid


(HawkEye) #5

The issue was htpasswd. The fix was to add: Require ip xx.xxx.xx.xxx to the <Directory /var/www/html/admin> in our ssl.conf
Thanks.


(HawkEye) #6

Also need to make sure the api_oauth.key is rw

chmod 600 api_oauth.key


(system) closed #7

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.