[SOLVED] Freepbx 14 - voice mail to email not working

I recently installed Distro Freepbx 14 to a Vultr virtual server. All has been working very well and I have been very impressed with Vultr thus far.

My only issue, is when someone leaves a voice mail it does not email the voice me to me like it used to when I was usiing Freepbx 13.

Any help here would be greatly appreciated.

From CLI, can you send test emails?

Not successfully. This is the result

[[email protected] ~]# sudo -u asterisk mail -s test1 [email protected]
Tis is a test emai
EOT
[[email protected] ~]#

I have 32 deferred - not sending

[[email protected] ~]# tail -f /var/log/maillog
Dec 10 21:12:17 bes postfix/qmgr[1252]: 61442315B944: from=<[email protected] s>, size=207870, nrcpt=1 (queue active)
Dec 10 21:12:17 bes postfix/qmgr[1252]: 2FF5A315B564: from=<[email protected] goma.local>, size=918272, nrcpt=1 (queue active)
Dec 10 21:12:17 bes postfix/qmgr[1252]: 8AC4230189C0: from=<[email protected] s>, size=437, nrcpt=1 (queue active)
Dec 10 21:12:17 bes postfix/qmgr[1252]: D2A4130189C2: from=<[email protected] s>, size=469, nrcpt=1 (queue active)
Dec 10 21:12:17 bes postfix/qmgr[1252]: 356E130189C1: from=<[email protected] s>, size=435, nrcpt=1 (queue active)
Dec 10 21:12:17 bes postfix/error[13695]: 61442315B944: to=<[email protected] >, relay=none, delay=4972, delays=4972/0.05/0/0.05, dsn=4.4.1, status=deferred ( delivery temporarily suspended: connect to mx2.emailsrvr.COM[173.203.187.2]:25: Connection timed out)
Dec 10 21:12:17 bes postfix/error[13697]: 8AC4230189C0: to=<[email protected] >, relay=none, delay=524, delays=524/0.06/0/0.03, dsn=4.4.1, status=deferred (de livery temporarily suspended: connect to mx2.emailsrvr.COM[173.203.187.2]:25: Co nnection timed out)
Dec 10 21:12:17 bes postfix/error[13695]: D2A4130189C2: to=<[email protected] >, relay=none, delay=361, delays=361/0.08/0/0.01, dsn=4.4.1, status=deferred (de livery temporarily suspended: connect to mx2.emailsrvr.COM[173.203.187.2]:25: Co nnection timed out)
Dec 10 21:12:17 bes postfix/error[13699]: 356E130189C1: to=<[email protected] >, relay=none, delay=475, delays=475/0.09/0/0, dsn=4.4.1, status=deferred (deliv ery temporarily suspended: connect to mx2.emailsrvr.COM[173.203.187.2]:25: Conne ction timed out)
Dec 10 21:12:47 bes postfix/smtp[13696]: connect to mx1.emailsrvr.com[173.203.18 7.1]:25: Connection timed out
Dec 10 21:13:17 bes postfix/smtp[13696]: connect to mx2.emailsrvr.com[108.166.43 .2]:25: Connection timed out
Dec 10 21:13:17 bes postfix/smtp[13696]: 2FF5A315B564: to=<[email protected] >, relay=none, delay=95177, delays=95116/0.03/60/0, dsn=4.4.1, status=deferred ( connect to mx2.emailsrvr.com[108.166.43.2]:25: Connection timed out)

I even tried to use my gmail email in case my email was the issue - same results - does not email the vm to me

You need to have port 25 open, both on your hardware and through your provider, many do not allow local mailservers so will block your emails

You need to speak to emailsrvr.com and get them to allow traffic from your vulr IP address. They are blocking you at a network level (or, possibly, Vultr are being good net-citizens and are not letting your machine send traffic over port 25?)

(Not Vultr and possibly nor necessesarily emailsrvr.com, it might just be your internet provider blocking 25)

You should be able to allow this in the vultr router configuration

The issue is that Vultr is blocking 25. They want me to submit a book report everytime I deploy a new server to open 25. Does Digial Ocean or Linode block 25? If is use them, is there an easy way to install FREEPBX on their VPS’s? I know they don’t have an easy gui for ISO upload. That is why I went with Vultr. They allow custom ISO image uploads

PitzKey- What do you mean I should be able to allow this in the Vultr Router config? I am using Vultr as the hosting provider, not router provider?

It is NOT disallowed by default because there is no default firewall, you would HAVE to add a policy with cognizance, I have literally many dozens of Vultr instances, none exhibit that behavior

I have no idea what you just said . . . Was that meant for another post?
.
Vultr did confirm - they block 25 and will not open it until I submit a volume of info every time I deploy a new server

I have never experienced that behavior from Vultr,every instance has postfix as the MTA working fine, both in and out.

Here is the reply I received from Vultr today:

Hello,

Thank you for your SMTP unblock request!

SMTP ports are blocked by default on all new Vultr Accounts and clients are asked to request removing the block off their accounts as needed.

This appears to be related to an Account Management issue. The Technical Support group does not have access to make account changes so we must now transfer this ticket to the Account Management group for attention.

Please note the Account Management group’s regular hours are approximately 9AM to 5PM US eastern daily. While they do their best to resolve any account-related issues in a timely manner, this will take some time. We thank you in advance for your patience.

In order to expedite this case, please be sure to reply to this ticket with the following information:

  1. The business name and organization URL(s) under which you offer services.
  2. Describe, in as much detail as possible, the nature of the emails you intend to send.
  3. The volume of email that you plan to deliver on a regular basis.

We need to know this in order to make an informed decision regarding your account settings and resource limits to ensure the integrity of our network/systems/online reputation.

If you feel I missed something technical, please refer to this Ticket ID in a new request and we will be sure to follow up.

Well hit me in the face with a cold kipper, I spun one instance up yesterday with absolutely no problem. . . .

I need port 25 so I can use voice mail to email.

Is your voicemail to email working?

Absolutely, so is email2fax for inbound and logwatch/fail2ban/csf outbound notifications, they always have. . . .

So I wonder why mine is not working …I deployed 5 vps’s on Vultr and not one of the will allow voicemail to email

DNS? Network settings maybe?

I can’t help there but everyone of our instances are fully externally resolvable by DNS