[SOLVED] Freepbx 12 Device Options Missing

In FreePBX 12 after you create an extension and apply the changes you can no longer see the device secret. The phone autoprovisions itself with an incorrect password and I am trying to find the right secret but it isn’t listed on the extension page. Is it tied to the password in the user management section? I have also tried changing it there but it still said incorrect password. I have tried finding the secret section in both chrome and firefox.

It’s there. It’s called “secret”.

What type of device are you creating?

I know its called secret, its a SIP device. Specifically Polycom IP 450 if that helps. I am on the extension page, typically it would be under the device options tab, however that isn’t showing on any of my extensions. If I create a new extension I can see it until I apply changes and then its gone.

I uploaded what I see on my extension page

You need to expand the sections. Somehow you collapsed every single one of them. Click the (+) next to each section and see if you can find it that way.

This wasn’t removed in 12, something is just funky with your setup.

I did that for security reasons, Which section is the secret supposed to be in?

Device Options but like you said you don’t have it. Something is wrong with your setup.

How did you install?


1 Like

Hi all,
I’m on freepbx 6.12.65-21(asterisk11) and in my extension I have no “Device options”. I’m not able to get the “secret” parameter of any device.
What can I do to solve the issue?

Are you sure you just don’t have that section collapsed? Is there a + next to the Device Options heading?

Yes, I’m sure. There is no “Device Options” at all.


The bug has been submitted, Andrew is working on it now. I have the same issue

I am trying to change the SIP password for an extension in FreePBX 12, but I caanot find the field. Short of deleting and reinstalling the extension, how can I change the PW?

Many thanks,


NOTE: This post moved from another topic.

This is a bug being worked on now.

OK< thank you. I will delete and re-add!

http://issues.freepbx.org/browse/FREEPBX-8245 I reported the bug yesterday, Andrew is working on it.

This is resolved with an upgrade to Fax Pro 12.0.28


Tested here, confirmed to be working.

1 Like

Confirmed fixed here as well. Thanks for the quick turnaround!


I don’t use “Fax Pro” and I too have “Device Options” missing under extensions. Installed this PBX a few weeks ago with the FreePBX distro from the FreePBX website. Running 6.12 just like “GRZMRC” is.