[Solved] Follow Me results in "sent to invalid extension but no invalid handler"

We’ve implemented a few FreePBX servers, but have never run into this issue before. When an extension has Follow Me disabled, there is no problem calling that extension from another extension. However, when Follow Me is enabled, we get a busy signal and the logs show this:

[2018-07-06 15:31:14] WARNING[6562][C-00000003] pbx.c: Channel ‘SIP/1-00000003’ sent to invalid extension but no invalid handler: context,exten,priority=followme-check,2,1

Everything is set to default - this is a brand new installation of FreePBX on the latest distro (12.7.5-1805-3.sng7).

The follow me list shows the extension, and then an external number (followed by #). I’ve tested removing the external number and just having the extension, and I’ve tested without the extension and just the external number. All result in the same log entry as shown above.


Sounds like there is something wrong with this context. When you go into extensions_additional and search for “followme-check” do you find it?

I was able to troubleshoot and finally get this working. The cause was the extension number. We were testing using extension # 1 and extension # 2. For some reason, Asterisk isn’t handling it correctly with Follow Me enabled. I created a new extension, # 40 and tested with that, and it worked.

To be totally sure this was the cause, I built a brand new FreePBX server, created extensions 1, 2, and 40, and tested it. Both 1 and 2 had the error, but 40 worked perfectly.

I’ll log this in the issue tracker.


Add a call trace to the report to prevent asking:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.