FreePBX | Register | Issues | Wiki | Portal | Support

[SOLVED] Follow-Me: Calls not going to cell phone VM


#1

Hello,

I am trying to setup FM for a user who wants the call to ring her desk phone for 3 rings then go to her cell phone, and then to her cell phone’s VM if she does not answer.

In the FM settings, I have “initial Ring Time” set to 18 seconds, the “Ring Strategy” set to “ringallv2-prim”, and the “Ring Time” set to 60 seconds (maximum I can set it). The user’s cell phone is the only entry on the FM list ans is entered as:

5555551234#

(though with the user’s actual cell number).

What is happening when someone calls in s the desk phone rings about 3 times as intended, and then he call does ring the user’s cell phone, but it never gets to her VM. I tested with my cell phone and what happens is my cell phone rings 3-4 times, then it stops and a couple seconds later my cell phone rings again 3-4 times and this repeats until I get tired of it and hang up. The whole time I am hearing ringing on my test call.

Why is the cell phone’s VM not picking up?

The “Destination for no answer” is set to “FollowMe -> Normal extension behaviour”, but i have tried other settings (such as Terminate Call -> Hang up), but the exact same thing happens.

Your insight is greatly appreciated!


(Itzik) #2

why do you use -prim?

Is call confirm on?

A call log will tell you whats up.


#3
  1. Because I believe it is the default (shouldn’t matter anyway, as it is the only entry. I have also tried “hunt” and just plain ‘ringallv2’ with same result)

  2. No, it is not.

  3. Call log just shows the system ringing the cell number over and over. No indication why it’s not letting my cell phone VM pickup the call.


(Lorne Gaetz) #4

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs


(Greg) #5

If you call her cell phone normally, does it go to her cell voicemail?

If not, that’s your problem.

I can’t think of any reason why a cell phone wouldn’t go to voicemail, unless it wasn’t enabled.


#6

Yes, calling either my user’s cell phone or mine directly goes to VM after 4 or 5 rings, so it’s not an issue of VM on the cell phone not being enabled.

The other odd thing I mentioned is that the call keeps looping, despite the “Destination if no answer” in the FollowMe settings being either “FollowMe -> Normal Extension Behaviour” or “Terminate Call -> Hangup”. I don’t see why the call should loop; at worst it should at least go to the user’s VM on the system or just terminate the call (depending which destination is active).


#7

I know how to get the logs, but all they show is just the call looping, calling the cell phone over and over. There is no indication of why.


#8

The logs would show the hangup cause. and the progression of the dialplan aferwards.


#9

I think I found the problem. In comparing the full call log of a FM that is working on the system (my test extension) and comparing to the one not working right, I found that when I call the DID for my test extension, my caller ID from where i am calling is getting passed through (i.i, “FROMEXTEN=5551239876”). When I call the DID linked to the extension having the FM problem, the caller ID comes through as anonymous (i.e., “FROMEXTEN=anonymous”).

To complicate matters more, when the call comes up on my cell phone, regardless of which extension I am calling, the caller ID of where I am calling from shows up.

Anyway, this is looking like a trunk provider issue and I am going to submit a ticket to them to check things on their side.

The two DIDs in question, even though they reside on the same system and are on the same SIP trunk account, the one seeming to have the problem belonged to another company that merged with my client, and the numbers were ported over from another provider. It looks like something funky got done on their setup :frowning:

I will let you know if that is indeed the resolution.


(Itzik) #10

One more thing I would try if it is only this extension which is causing issues, to delete the extension, apply config and re-create.


#11

I actually tried deleting the extension, applying the config, the adding the extension back, but the problem persisted. I am almost certain it has to do with how the trunk provider is passing the CID to us.


#12

OK, so it looks like I have this resolved, but you are not going to believe what the solution is. The DID I was testing with that worked as expected has “Fax Detection” enabled, and the DID of the user having the problems did not. I enabled “Fax Detection” on the user’s DID, applied the config and tested. FM started working as expected.

WTF?


(Dave Burgess) #13

We’ve actually seen this before. The “FAX Detection” option answers the call immediately and listens to the RTP stream for FAX tones. If they don’t come in, the call is routed to a voice destination. I’m not sure why the “early” pick up helps, but it seems to.


(Itzik) #14

If this is the case, there’s a Answer toggle in the inbound route, try enabling just that.


#15

Are you referring to the “Pause before answer” setting on the “Advanced” tab? I don’t see just a stand-alone “Answer” toggle on any of the tabs for the settings of a particular inbound route.


(Lorne Gaetz) #16

It’s a feature added in 14.


#17

Ah, OK. They are on 13 (I never specified that, so I can’t fault you for the suggestion :slight_smile: )