[SOLVED] DIDs not working on Freepbx 5.2.11 Asterisk 1.8.27

Hello Everyone

I just installed freepbx 5.2.11 with Asterisk 1.8 full install with a Digium TE133 T1 configured card. Almost everything works fine I can make and receive calls. However the DIDs I have configured don’t work. I have configured several but all of them take me to the IVR that I configured as well as the default any DID /any CID does it. I have created an inbound route with the DID number for veryone but they simply don’t work. I configured everything through the web interface. Any Ideas??


Have you looked at the logs to see what your provider is sending as DID’s?

Thans for our repsonse I have, however I am not very proeficient reading the logs. This is an example of one of the calls in var/log/asterisk/full. I only can see clealry the call going into the IVR and not to the DID I want. I am dialing from one of my extensions to my own DID and have dial 9 to get out. my extension is 5180 and is called Xlite Test. I


This is only the incomming call.


I figure it out. According to the logs,
my provider was only deliveryng the las three digits of the DID. So configured every DID correctly and the issue was solved.

Thanks a lot for your help.


3-4 digits is pretty common on pri. Usually 10-11 on sip

I always request the provider send 10 digits.