[SOLVED] Dial pattern with star (*) and pound (#) doesn't execute


I’m trying to create dial pattern that matches 2 numbers separated by star () or pound (#) sign. I manipulate these numbers later in the dialplan.
That’s what I tried to implement:

exten => _7XXXXXXXXXX
10000,1,NoOp(FULL called number is ${EXTEN})
exten => _7XXXXXXXXXX10000,n,Set(MY_FIRST_NUM=${CUT(EXTEN,,1)})
exten => _7XXXXXXXXXX10000,n,Set(MY_SECOND_NUM=${CUT(EXTEN,,2)})

When I try to call 71234567890*10000 I always get “bad number”. The ${EXTEN} shows first part only and ${MY_SECOND_NUM} is empty. It tried with # instead of * but no luck.
As far as I understood, star- and pound- separated numbers are stripped and/or omitted somewhere, so the ${EXTEN} passes to route already cut by half.

It works with plus (+) as separator, but not all phones including sofphones have a (+) button, so I have a goal to keep with these “easy” separators. Please, share your knowledge.

Update! Sorry for the disinformation, problem roots lie in the X-Lite which was stripping the “DTMF” part. With the 3CX Phone there is no problem.