[SOLVED] Dashboard title menu missing after module upgrade

Hello,

I just updated a bunch of FreePBX 14 modules however I believe I’m having a minor issue with the System dashboard module since upgrading where the title menu bar is missing.

System Dashboard 14.0.4.4 will be upgraded to online version 14.0.6.2
[[email protected] etc]# fwconsole ma list | grep “dash”
| dashboard | 14.0.6.2 | Enabled | AGPLv3+ |
[[email protected] etc]# cat /etc/schmooze/pbx-version
12.7.5-1902-3.sng7

If I add ?display=index_ after the URL then all works as expected.

Ignore the SSL warning - These screenshots were taken on my warm spare box.

Cheers.
Fraser

Are you logged in with a user that was generated via User management with Full Admin Rights set to Yes instead of selecting the modules from the drop down menu below this option?

1 Like

Thanks!

Your message got me thinking - I tried logging in using fwconsole unlock [SessionID] and this worked!

So, I went into User Manager and my permissions looked like this:


I’ve changed Administration Access to Select All, clicked Apply, logged out then back in and it started working as normal.

Strange as I thought Grant Full Administration Rights overruled this setting. Also, strange that I could still access all the Admin pages using ?display=

Thanks,
Fraser

No problem. I ran into the same thing a few days ago. Prior to a patch it actually gave an error when you tried to login. The search bar still works which does allow for some navigation but your previous settings should have been good and I’m sure will be good once the bug is patched.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.