[solved] cron error: 'module_xml' is marked as crashed and should be repaired

This came out of nowhere today - running FreePBX on a raspberry pi. Relatively recent install - still configuring but no changes for several days. Is there a “repair” db command that I can try? My only backups are full image backups and the last one is only a few days old - it’s just a time-consuming way to do a restore if not necessary and I am not on site and it would have to wait at least a day. If there is no DB repair I can try, in the interim, what do I stop in cron to stem the flow of error emails?

That error points to a mysql error in your module_xml table.

You should probably start with:-


but downline make sure your storage on the rasbpi “up to scratch” many suggest you move the dynamic content to a usb disk, but as both usb disks and cf cards use the same technology for storage I am not convinced. . .

Dicko - thanks. I had trouble figuring out which DB the module_xml table is in - can you enlighten me? And do you know where /var/lib/asterisk/bin/freepbx-cron-scheduler gets run? I just want to put it on hold until I fix this. Thanks!


you probably need to mess with
itself it is what it says

But really why not just fix it, if you don’t care that you have a problem, then just change your email notification address, you will no longer be bothered with usually important information :wink:

Yeah I could do that! Don’t worry I will fix it - I just only have a few snatches of 10 minutes each until tomorrow so I won’t have time to look into the fix - I tried quickly and got a password error (!) so I think this might take more time than I have now. I’m getting emails on my phone every 20 minutes and thought I could comment out a line in crontab and hold them off for now. Thanks for the help. I’ll give the repair a shot. Actually this makes me think I’ll probably go to a small format unit with an actual drive if these SDcards are going to have read/write issues. I have one partially set up so not a big deal…

mysqlcheck did the trick. I had to use user and password from amportal.conf. Thanks Dicko.