[SOLVED]Chan_Mobile Freepbx on Asterisk16.xx


(Rui Brito Da Silva) #1

I’ can’t load Chan_Mobile.so on asterisk! I’ve created even an chan_mobile.conf file in /etc/asterisk

when I do:
asterisk -rx “module show” | grep chan_mobile
chan_mobile.so Bluetooth Mobile Device Channel Driver 0 Not Running extended

Bluetooth does work and find devices without a problem!
hcitool scan
Scanning …
48:50:XX:XX:XX:XX Windows phone
70:BB:XX:XX:XX:xx XiCS

what could be wrong?


Solution
So, I did a fresh install of Freepbx & Asterisk 16
After that, tried do load Chan_mobile.so. It was missing BT adapter!

I’ve followed this link - Where it’s says - " Adding chan_mobile support"
https://jtanx.github.io/2016/02/24/using-asterisk-to-route-calls-through-mobile/

Then, stopped at SIP setup, because i’m not using SIP Settings! I’m using a dongle!

After several tests with sip trunks and costum trunks, I was able to make outgoing calls trough costum trunk with this string:

Mobile/xxxxxxx/$OUTNUM$ (xxxxx is the name that you give on Chan_Mobile.conf of your paired mobile phone)

In the Inbound route, I couldn’t establish DID or CID, strange…it doesn’t work.
It works only without any DID & CID. If you give some number, it will not work. (but I will do more tests in the future).
After this, audio was only in one way. After several searches, somewhere here, it says to change “incoming-mobile” to “from-trunk” on chan_mobile.conf

After doing that change everything is working! Incoming & Outgoing calls!

By the way: It works with a BT Dongle Trust 2.0, an Microsoft (Nokia) Lumia 640XL and an LG-D390n without any problem (I’m telling this, because i’ve read on other sites about audio distortion e uncompatible phone models)

Hope this helps other people with this kind of problems!