[SOLVED] Can't load extensions page when fax configuration is enabled

I am getting this output when I try to go to an extensions page such as mypbx/admin/config.php?display=extensions&extdisplay=666

This only happens with Fax Configuration 12.0.5 enabled on FreePBX 12.0.17 using Asterisk 13.0.1
It happens regardless of whether or not my FaxPro 12.0.31 is enabled.

[code]FATAL ERROR

DB Error: unknown error

Error selecting from fax

Trace Back

/var/www/html/admin/modules/fax/functions.inc.php:425 die_freepbx()
[0]: DB Error: unknown error

Error selecting from fax

/var/www/html/admin/modules/fax/functions.inc.php:192 fax_get_destinations()

/var/www/html/admin/helpers/freepbx_helpers.php:123 fax_destinations()

/var/www/html/admin/libraries/components.class.php:806 drawselects()
[0]:
[1]: 0
[2]:
[3]:
[4]: Unavail Voicemail if Enabled
[5]:

/var/www/html/admin/modules/core/functions.inc.php:6770 gui_drawselects->gui_drawselects()
[0]: noanswer_dest
[1]: 0
[2]:
[3]: No Answer
[4]: Optional destination call is routed to when the call is not answered on an otherwise idle phone. If the phone is in use and the call is simply ignored, then the busy destination will be used.
[5]:
[6]:
[7]: Unavail Voicemail if Enabled

/var/www/html/admin/libraries/components.class.php:466 core_users_configpageload()
[0]: extensions

/var/www/html/admin/config.php:316 component->buildconfigpage()[/code]

Okay, solved it…

This one was because the mysql user couldn’t write to /tmp for some reason; chmod 777 fixed this one. Not sure how/why this happened but posting in case someone runs into the same problem.

1 Like