Solved: Cannot install customcontexts module on FreePBX 13 distro


#1

I have 2 FreePBX 13 distros and I have custocontexts module on one of them but it is missing on the other one. Is there a setting which hides it?

fwconsole ma listonline

No repos specified, using: [standard,commercial,extended] from last GUI settings

±---------------------±------------±------------------------------±-----------+
| Module | Version | Status | License |
±---------------------±------------±------------------------------±-----------+
| accountcodepreserve | 13.0.2.2 | Enabled and up to date | GPLv2 |
| amd | 13.0.3 | Enabled and up to date | GPLv3+ |
| announcement | 13.0.7.8 | Enabled and up to date | GPLv3+ |
| areminder | 13.0.10.12 | Enabled and up to date | Commercial |
| arimanager | 13.0.5.4 | Enabled and up to date | GPLv3+ |
| asterisk-cli | 13.0.4 | Enabled and up to date | GPLv3+ |
| asteriskinfo | 13.0.7.2 | Enabled and up to date | GPLv3+ |
| backup | 13.0.27.24 | Enabled and up to date | GPLv3+ |
| blacklist | 13.0.14.13 | Enabled and up to date | GPLv3+ |
| bria | 13.0.20 | Enabled; Not available online | Commercial |
| broadcast | 13.0.12.16 | Enabled and up to date | Commercial |
| builtin | | Enabled; Not available online | |
| bulkdids | 13.0.2 | Enabled; Not available online | GPLv3+ |
| bulkextensions | 13.0.3 | Enabled; Not available online | GPLv3+ |
| bulkhandler | 13.0.19 | Enabled and up to date | GPLv3+ |
| callback | 13.0.5.5 | Enabled and up to date | GPLv3+ |
| callerid | 13.0.8.20 | Enabled and up to date | Commercial |
| callforward | 13.0.4.2 | Enabled and up to date | AGPLv3+ |
| calllimit | 13.0.5.7 | Enabled and up to date | Commercial |
| callrecording | 13.0.11.15 | Enabled and up to date | AGPLv3+ |
| callwaiting | 13.0.4.1 | Enabled and up to date | GPLv3+ |
| campon | 13.0.4.1 | Enabled and up to date | GPLv3+ |
| cdr | 13.0.35 | Enabled and up to date | GPLv3+ |
| cel | 13.0.26.12 | Enabled and up to date | GPLv3+ |
| certman | 13.0.41 | Enabled and up to date | AGPLv3+ |
| cidlookup | 13.0.12.5 | Enabled and up to date | GPLv3+ |
| conferences | 13.0.23.17 | Enabled and up to date | GPLv3+ |
| conferencespro | 13.0.27.14 | Enabled and up to date | Commercial |
| configedit | 13.0.7.1 | Enabled and up to date | AGPLv3+ |
| contactmanager | 13.0.45.4 | Enabled and up to date | GPLv3+ |
| core | 13.0.131.26 | Enabled and up to date | GPLv3+ |
| cos | 13.0.12.7 | Enabled and up to date | Commercial |
| customappsreg | 13.0.5.7 | Enabled and up to date | GPLv3+ |
| cxpanel | 13.0.5.5 | Enabled and up to date | GPLv3 |
| dahdiconfig | 13.0.33.16 | Enabled and up to date | GPLv3+ |
| dashboard | 13.0.26.2 | Enabled and up to date | AGPLv3+ |
| daynight | 13.0.15.1 | Enabled and up to date | GPLv3+ |
| dictate | 13.0.5 | Enabled and up to date | GPLv3+ |
| digium_phones | 13.0.7.4 | Enabled and up to date | GPLv2 |
| digiumaddoninstaller | 2.11.0.12 | Enabled; Not available online | GPLv2 |
| directory | 13.0.19.12 | Enabled and up to date | GPLv3+ |
| disa | 13.0.6.12 | Enabled and up to date | AGPLv3+ |
| donotdisturb | 13.0.3.1 | Enabled and up to date | GPLv3+ |
| endpoint | 13.0.133.3 | Enabled and up to date | Commercial |
| extensionroutes | 13.0.10 | Disabled | Commercial |
| fax | 13.0.40.7 | Enabled and up to date | GPLv3+ |
| faxpro | 13.0.44 | Enabled and up to date | Commercial |
| featurecodeadmin | 13.0.6.4 | Enabled and up to date | GPLv3+ |
| findmefollow | 13.0.38.13 | Enabled and up to date | GPLv3+ |
| firewall | 13.0.60.3 | Enabled and up to date | AGPLv3+ |
| framework | 13.0.197.22 | Enabled and up to date | GPLv2+ |
| freepbx_ha | 13.0.11 | Enabled and up to date | Commercial |
| fw_langpacks | 12.0.7 | Enabled and up to date | GPLv3+ |
| hotelwakeup | 13.0.17.2 | Enabled and up to date | GPLv2 |
| iaxsettings | 13.0.6.6 | Enabled and up to date | AGPLv3 |
| infoservices | 13.0.1.4 | Enabled and up to date | GPLv2+ |
| irc | 13.0.1 | Enabled and up to date | GPLv3+ |
| ivr | 13.0.27.21 | Enabled and up to date | GPLv3+ |
| languages | 13.0.6.5 | Enabled and up to date | GPLv3+ |
| logfiles | 13.0.10.10 | Enabled and up to date | GPLv3+ |
| manager | 13.0.2.7 | Enabled and up to date | GPLv2+ |
| miscapps | 13.0.3.2 | Enabled and up to date | GPLv3+ |
| miscdests | 13.0.9 | Enabled and up to date | GPLv3+ |
| music | 13.0.22.8 | Enabled and up to date | GPLv3+ |
| outroutemsg | 13.0.2.2 | Enabled and up to date | GPLv3+ |
| paging | 13.0.26.19 | Enabled and up to date | GPLv3+ |
| pagingpro | 13.0.19.20 | Enabled and up to date | Commercial |
| parking | 13.0.19.11 | Enabled and up to date | GPLv3+ |
| parkpro | 13.0.30.22 | Enabled and up to date | Commercial |
| pbdirectory | 2.11.0.6 | Enabled and up to date | GPLv3+ |
| phonebook | 13.0.6.5 | Enabled and up to date | GPLv3+ |
| phpinfo | 13.0.2 | Enabled and up to date | GPLv2+ |
| pinsets | 13.0.13 | Enabled and up to date | GPLv3+ |
| pinsetspro | 13.0.9.14 | Enabled and up to date | Commercial |
| pm2 | 13.0.7.1 | Enabled and up to date | AGPLv3+ |
| pms | 13.0.2.58 | Enabled and up to date | Commercial |
| presencestate | 13.0.8.4 | Enabled and up to date | GPLv3+ |
| printextensions | 13.0.3.2 | Enabled and up to date | GPLv3+ |
| queueprio | 13.0.7 | Enabled and up to date | GPLv3+ |
| queues | 13.0.34.17 | Enabled and up to date | GPLv2+ |
| qxact_reports | 13.0.15.18 | Enabled and up to date | Commercial |
| recording_report | 13.0.24.11 | Enabled and up to date | Commercial |
| recordings | 13.0.30.14 | Enabled and up to date | GPLv3+ |
| restapi | 13.0.21.2 | Enabled and up to date | AGPLv3 |
| restapps | 13.0.93.3 | Enabled and up to date | Commercial |
| ringgroups | 13.0.23.4 | Enabled and up to date | GPLv3+ |
| rmsadmin | 13.0.14.1 | Enabled; Not available online | Commercial |
| sangomacrm | 13.0.8 | Enabled and up to date | Commercial |
| setcid | 13.0.6.3 | Enabled and up to date | GPLv3+ |
| sipsettings | 13.0.27.8 | Enabled and up to date | AGPLv3+ |
| sipstation | 13.0.16.5 | Enabled and up to date | Commercial |
| sms | 13.0.12.5 | Enabled and up to date | Commercial |
| sng_mcu | 13.0.5 | Enabled and up to date | Commercial |
| soundlang | 13.0.27 | Enabled and up to date | GPLv3+ |
| speeddial | 2.11.0.4 | Enabled and up to date | GPLv3+ |
| superfecta | 13.0.4.8 | Enabled and up to date | GPLv2+ |
| sysadmin | 13.0.94 | Enabled and up to date | Commercial |
| timeconditions | 13.0.34.11 | Enabled and up to date | GPLv3+ |
| tts | 13.0.13 | Enabled and up to date | GPLv3+ |
| ttsengines | 13.0.7.5 | Enabled and up to date | AGPLv3 |
| ucp | 13.0.42.7 | Enabled and up to date | AGPLv3+ |
| ucpnode | 13.0.34.11 | Enabled and up to date | Commercial |
| userman | 13.0.76.44 | Enabled and up to date | AGPLv3+ |
| versionupgrade | 13.0.1.6 | Enabled and up to date | Commercial |
| vmblast | 13.0.11 | Enabled and up to date | GPLv3+ |
| vmnotify | 13.0.22.5 | Enabled and up to date | Commercial |
| voicemail | 13.0.59.5 | Enabled and up to date | GPLv3+ |
| voicemail_report | 13.0.13.8 | Enabled and up to date | Commercial |
| vqplus | 13.0.42.18 | Enabled and up to date | Commercial |
| weakpasswords | 13.0.2 | Enabled and up to date | GPLv3+ |
| webcallback | 13.0.11.5 | Enabled and up to date | Commercial |
| webrtc | 13.0.32.9 | Enabled and up to date | GPLv3+ |
| xmpp | 13.0.19.1 | Enabled and up to date | AGPLv3 |
| zulu | 13.0.56.16 | Enabled and up to date | Commercial |
±---------------------±------------±------------------------------±-----------+

fwconsole ma install customcontexts

Unable to install module customcontexts:

  • Cannot find module
    Updating Hooks…Done

#2

It seams that this is unsupported module because when I checked Unsupported, it appeared.


(Dave Burgess) #3

I don’t remember why the module ended up being deprecated, but it seems to me that the functionality it provided got pulled into other modules.


#4

If its functionality is moved to other modules, I don’t know how to use it there.