Softphone to freepbx - Authentication Failed Help Please

Hi, i am a rookin on this matter, im a a rookie on networks to be honest.

I´m on my final year of 12th grade (portugal), ad i a an intern on a buiseness and my function is to build and implement a voip server so the workers can call between themselves, do outbound calls and recieve inbound.

I have installed:

UBUNTU SERVER 12 LTS as base os

Asterisk 11.3.o as pbx

and finnaly

FreePBX 2.10

The network is set and the extentions too

so the problem is:

When i try to connect the softphone 3CX to the PBX i get a “authentication failed” error

Here is the debug console

and the profile configurations

so once again, the proble is , i cant authenticate on the pbx server, how can i resolve this problem ? Help please.
if it is needed any other logs warn me and i will provide.

Now that i remember here it is also a asterisk console

I have tried with x-lite 4 and it doesn’t seem to work too, this time the softphone says it could authenticate and there is no warnings on the server…

from the putty console:

x-lite 4 softphone

x-lite 4 softphone account definitions

im reaching the bottom line to deliver the project about 12 days need serious help please. if it is any good i could manage to get some one to remotely access my computer ( team viewer or some software like that) so it could help-me to get this corrected. if anyone intrested i am on a GMT Lisbon timezone.


You should not promise work that you are not capable of delivering and then expect the forum to teach you how to do your job.

What compensation are you offering this individual to remote into your system?

Sorry if i transmitted a meaning of “cockiness”, it was not my intention…
This job was told to me to do it and even saying that i didn´t knew how to do it my employer told-me to go search how to do it it… ( he is somewhat of a “prick” excuse me the expression).

Everything that i have made was purely based on search on the internet and learning from myself.

As a student i can not offer any kind of monetary or object compensation… and also because i do not have ways to pay to someone.

I have searched forums and forums, read manuals and other guides and i can not get this done…

I would once again ask for a helpfull hand…

Best Regards

Scott, this reminds me of a guy last week on the Schmooze sales chat that needed help with his homework. His professor had tasked him with building a FreePBX server and he had broken his install… maybe that’s a new revenue source for the project homework cheats?

Koztax, Just a quick look, it appears you created extension 1001 in FreePBX, but are trying to register with 1002. I would suggest that instead of trying to install under ubuntu for your first endeavor that you stick with centos, and using the FreePBX Distro. You will see a download link for it at the top right of this page.

Thank you, i have both extensiona added, btw now surges another problem, i have freepbx instaled on a VM, oracle virtualbox and on boot it says to connect to to get to the GUI.

My browser ( google chrome) can not acess the page, it says that it vould´t establisha a connection. any clue.

It would´t be considered cheating if i´m not at school, as i said i ama an inter on a buiseness.

Probably an issue with your virtualbox network connection and bridging, if you browser can’t see the GUI your phones most likely are going to have a bad time. Like I said before, since you are installing virtually, I would give the distro a quick install and see if that fixes your problems.

If you are an Intern that you should not be under pressure.

If you don’t understand networking and basic telephony you should tell your supervisor so they can remediate.

From my perspective it’s a simple matter of you slowing down and reading documentation.

Now you are asking for help with network we know nothing about. If you read our documentation you would know the web server (and all services) bind to all IP’s by default.

Ok will do a review of my installation and my network set up.
I have advised my monitor about my knowledge since day 1.
Will post feedback when i have it.

Thank you


We do appreciate the feedback. It assists us in developing new features and documentation.

I´ve tried your distro and seems to be working all fine, sorry for bothering you and decorating this forum with my ignorance and consuming your time.
I will procede now to install the FreePBX distro on the server machine and feedback will be posted later

Once again

Thank you

Best Regards

Well after installing the freepbx distro and adding 4 extension al worked right i can now make calls.

But as a good newby on the matter a new problem apeears. After acessing for the first time the web gui, with success, i can no longer connect to it
all the connections are fine and the instalation too…

But then again

Thank for your advice

Best Regards

solved it … no problemo…

Hi koztax,
I went through your postings. I could feel your disappointments, frustrations and then happiness.
This is a “lesson learned” for all of us, including myself. The FreePBX is designed for running on CentOS, there is no trick, no complexity, very simple ! I am happy to see that you could finally found the solution after suggestions from this forum and installing FreePBX from scratch. Being in the technical career for decades, my suggestion is, “always follow the instruction and documentations”, never try to reinvent the wheel. As a patron of many opensource applications, I found FreePBX has one of the best documentations to be followed, which I would think (jokingly), even my 90 years old grandma could build a PBX.

Take care.