So far not impress

i just finished installing the module and tried two phone a grandstream 1450, and a cisco 501g. Both generated config files in the tftboot. but no phone registered yet…

so i tail -f /var/log/messages

to see
localhost in.tftpd[5579]: tftpd: read(ack): Connection refused

i was running oss endpoint until today really fine no (Edited out profanity)

now i pay for a better module and it’s not working out of the boxe

and missing some basic thing like showing registered phones like oss.

there is some work to do guys!

a brand new customer…

I can tell you we have thousands of customers using this module with no issues.

Regardless sounds like you have a TFTP issue based on your error and EPM has nothing to do with TFTP setup or management.

Secondly using language like F*** is not tolerated here and you will be banned if it happens again.

i just upgraded from the oss as explained in schmooze wiki
followed all instructions. the oss was running just fine before

what is a little hard to accept is that out of the box oss is working… and the the paid is not.
it may be nothing very complicated like permission or something
but still it need to be corrected

im running asterisk since the beginning and tried a lot of distribution. My hope in buying module is to get what is the best available and im sure you understand me on this point.

so if you have any clue why permission are not set to acces tftboot or whatever is blocking in.tftpd

please let me know.

Did you uninstall the OSS module? Do you have configs generated by the OSS module still remaining on your system that you have not deleted?

right now the cisco501g get the config but reboot at 15 interval or so …
so i know that tftp can provide files…

i did reboot the server once

and my apologies if i was a little rude here in quebec the word f
is somewhat used differently!

You didn’t answer Preston’s question about uninstalling the old one. That can cause all sorts of issues.

The Commercial EPM also shows you registered phones and if you click the link will even take you to the web interface of the phone.

i followed up the tuto on removing oss endpoint and deleted the tftpboot dir. i will try uninstall the schmooze module and reinstall to see if anything new happen

i uninstalled the module upgraded freepbx to
factory resetted the grandstream 1450. and i got this

n 6 08:30:13 localhost dhcpd: DHCPACK on 00:0b:82:36:c6:5e via eth0
Jun 6 08:31:10 localhost in.tftpd[15644]: tftpd: read: Connection refused
Jun 6 08:31:10 localhost in.tftpd[15645]: tftpd: read: Connection refused
Jun 6 08:31:10 localhost in.tftpd[15646]: tftpd: read: Connection refused
Jun 6 08:31:10 localhost in.tftpd[15647]: tftpd: read: Connection refused

but the phone got registered!!!

can someone explain me why i get connection refused???..

the 1450 correctly register im able to reboot it from extension mappion but it’s not showing like the cisco any clue?


The phone registered because you configured it before and it’s just loading its old config data. You probably don’t have the tftp server running

tm100 you probably not read previous posts. The just above you see a a tail showing that the tftp is running.
im switching back to oss.

“tftpd: read: Connection refused” has nothing to do with OSS or the Commercial one. It’s a misconfiguration with your tftp server. Doesn’t matter if it’s running, if you have wrong permissions or misconfiguration you will get those errors.

I just recently removed OSS and installed EPM and just like the original poster, I too am not impressed.

I am confident that, once I learn the software, it WILL do all the things I want it to do - but that said, the one thing it is NOT - is intuitive. The EPM and the documentation for the EPM seem to assume a background and level of experience that the user (at least me!) does not have. If I take the documentation at face value - the business of America is monitoring the Busy Lamps on other stations… but adding a second or third extension to an existing instrument is so fall-off-a-log easy that it requires no documentation at all.

I’m not sure what a account1 thru account4 are either, but apparently a lot of people can’t run their businesses without assigning accounts to phones.

Even my extensions list doesn’t look like the documentation – every instrument is crammed into two lines on the left, with the middle of the screen totally empty and the other selections on the far right.

I uninstalled OSS and lost all the MAC data in my extensions. EPM’s “Scan Network” yielded no data. Just none. The Linux ARP command sees them just fine, but not “Scan Network” On the flip side, import CVS saved the day – but I expected the scan to report results.

Yesterday I created and saved a template. Today I opened it and added a speed dial number. When I pressed SUBMIT and waited I got a pop-up saying “fail.” No message I can work with, just “fail.”

I went back to the documentation and did a search on “log file” and there does not appear to be documentation on where EPM logs its errors so that I might learn what I did wrong.

My 2 cents? As someone who has been in the computer business back when we used 16 bit core memory on our Data General Novas… it isn’t productive to try to solve a customer support issue by telling us that other people aren’t having issues. The fact that thousands of people use the software without complaint in no way diminishes the OP’s problems but rather the reverse: It carries the subtle implication that if we, the unwashed masses were not so breathtakingly stupid and unbelievably ignorant - it would not be necessary to write more intuitive code.

To continue … as I get more immersed, one person’s “extension” is another person’s “account” So what I needed to do is add 2 extensions with the same MAC address and select the second record to account2 to get it to ring on line two of the same instrument.

So as I suspected - it IS all there. I will eventually be able to build a template that sets line 4 in “no ring”, etc.

but until then – it’s like thinking that all of Shakespeare is in the dictionary – all you have to do is read the words in the right order.

Thanks for your well thought out and well rounded thoughts. It’s much appreciated to have someone be respectful to all of us and express their opinions as such. In FreePBX 12 we are trying to clean up Endpoint Manager to make it more user friendly but that doesn’t mean it will be what you want. We walk that fine line of “how many features do people want or do we add”. The more features we add (to freepbx or anything) the more people say it’s bloated and confusing, the less features we add the more our advanced and experienced users say it’s dumbed down. Back and forth. You know it, you’ve seen it. Anyways I am just tangenting for no reasoning.

Like I said, we are improving the experience. I work for schmooze and even I think it can be hard to wrap my head around sometimes. I have not reviewed the new 12 version yet but I am hoping it will be closer to what you are looking for.

In terms of EPM logs, they are in the same place as all FreePBX logs and can easily be viewed by running: amportal a dbug or tailing the freepbx log in /var/log/asterisk/freepbx.log

Yes, I’ve been on both sides. The story below is true. It happened to me, personally.

OK - after the mini-rant I face my first operational challenge.
Ext 106 is now defined in the EPM and all looks good.
check it’s box, select SAVE and press USE SELECTED.
screen reloads, no problem.

Check the box again, select “rebuild configs” / Use Selected.

Screen clears
Screen appears as “end point manager” and a horizontal rule
Nothing else.
waited 10 minutes. No change.

Repeated twice. Same results.

nothing logged in freepbx.log

Where should I start looking?

I am not making this up once when a man called with an issue that his CPU wouldn’t boot and we asked him to read the LEDS on the board –

but he couldn’t see the LEDS
–after another 10 minutes of investigation–
because of the glare
from the sun
from the hole
that the fire department chopped
to put out the fire in his computer room

So yeah – I get it.


One of the interesting challenges is phone guys don’t get the client/server and networking stuff. Computer guys don’t get the phone stuff.

Hence we have challenges imparting information. I have to say at $75.00 the EPM is quite a value. With over 1000 phones deployed with it myself and myself have become comfortable with the nuances. I assume in time you too will come to view it as an indispensable part of your FreePBX toolbag.

As far as this goes:

"" It carries the subtle implication that if we, the unwashed masses were not so breathtakingly stupid and unbelievably ignorant ""

I laughed so hard I fell out of my chair. I have a reputation as a chop buster but would not use those words to describe a user. That’s quite a bit of self actualization. I wouldn’t be so hard on yourself <> DRINK


amportal a dbug (and the cause the blank page)

Or look for error_log in /var/log/httpd

[Thu Jun 12 12:03:32 2014] [error] [client] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/html/admin/libraries/utility.functions.php on line 393, referer:

Output from amportal a dbug:

a loop of output:
2014-Jun-12 12:05:25 /var/www/html/admin/modules/endpoint/*
[NOTICE]: Undefined index: exp1_83228**_type

  • 316 & 319 alternating
    ** with the 83228 being an incrementing number