SNG7 - Certificate Management

There appears to be a bug in the latest FreePBX 14 beta. The “New Certificate” button is not functional.

In the mean time as a workaround, I would like to use the “Import Locally” option. What directories do I need to upload the certificate and private key for this option to work?

It’s working here. Please state the browser you are using and the version of Certificate Manager

There is no way to do this at this time. It must all be done through the GUI

Hi Andrew,

Thanks for the quick reply. The problem persists in Firefox, chrome, and IE.

Certificate manager version 13.0.34

FreePBX 14 asterisk 14

Nothing happens, no drop-down options.

Please update your modules. This was fixed about five months ago…

Certificate Manager

Oops. My bad. I did a fresh installation today.

Didn’t realize the distro didn’t auto-update to the latest modules during installation.

It does. If the internet is properly configured during boot. If not then there’s nothing it can do.

I installed it on a VPS.

Firewall allows all outbound. No inbound ports open except for 22 and 443 open from a specific IP so I could configure it.

Do specific inbound ports needs to be open during installation?

Andrew misspoke here. The 10.13.66 Distro does auto update at install the new SNG7 does not as users asked us not to anymore.

1 Like

Thanks for the clarification.