SNG7 and 911 woes

Recently we have been rolling out SNG 7 64-bit Stable. All the systems that we have loaded or upgraded to SNG 7 have had issues with 911. Currently, when an endpoint dials 911, it fails with the following:

pbx.c: Executing [[email protected]:1] NoOp(“SIP/192.168.2.254-00000064”, “Received incoming SIP connection from unknown peer to 911”) in new stack

192.168.2.254 is the PBX. I would expect to see it being directed to the dial tone provider.

An emergency route is set first in the list with the entry of 911. The trunk it uses is the dial tone provider. This is only happening for 911. Other 3 digit numbers work. I added 411 to the below config and 411 works; however, 911 does not.

[outrt-16] ; e911
include => outrt-16-custom
exten => 411,1,Macro(user-callerid,LIMIT,EXTERNAL,)
exten => 411,n,Gosub(sub-record-check,s,1(out,${EXTEN},dontcare))
exten => 411,n,ExecIf($[ “${CALLEE_ACCOUNCODE}” != “” ] ?Set(CDR(accountcode)=${CALLEE_ACCOUNCODE}))
exten => 411,n,Set(EMERGENCYROUTE=YES)
exten => 411,n,Set(MOHCLASS=${IF($["${MOHCLASS}"=""]?default:${MOHCLASS})})
exten => 411,n,ExecIf($["${KEEPCID}"!=“TRUE” & ${LEN(${DB(AMPUSER/${AMPUSER}/outboundcid)})}=0 & ${LEN(${TRUNKCIDOVERRIDE})}=0]?Set(TRUNKCIDOVERRIDE=7045224970))
exten => 411,n,Set(_NODEST=)
exten => 411,n,Macro(dialout-trunk,2,${EXTEN},off)
exten => 411,n,Macro(outisbusy,)

exten => 911,1,Macro(user-callerid,LIMIT,EXTERNAL,)
exten => 911,n,Gosub(sub-record-check,s,1(out,${EXTEN},dontcare))
exten => 911,n,ExecIf($[ “${CALLEE_ACCOUNCODE}” != “” ] ?Set(CDR(accountcode)=${CALLEE_ACCOUNCODE}))
exten => 911,n,Set(EMERGENCYROUTE=YES)
exten => 911,n,Set(MOHCLASS=${IF($["${MOHCLASS}"=""]?default:${MOHCLASS})})
exten => 911,n,ExecIf($["${KEEPCID}"!=“TRUE” & ${LEN(${DB(AMPUSER/${AMPUSER}/outboundcid)})}=0 & ${LEN(${TRUNKCIDOVERRIDE})}=0]?Set(TRUNKCIDOVERRIDE=7045224970))
exten => 911,n,Set(_NODEST=)
exten => 911,n,Macro(dialout-trunk,2,${EXTEN},off)
exten => 911,n,Macro(outisbusy,)

Any help is appreciated.

PBX Firmware:
12.7.4-1802-3.sng7
PBX Service Pack:
1.0.0.0

Your extension “192.168.2.254”. Is not registered to the system or is dialing through SIP URIs. If this was working it would show “SIP/”. Therefore it’s hitting an inbound route “from-sip-external”.

Disable allow guests and allow anon calls and you’ll quickly see you can’t make any calls.

My Spidey sense is telling me you are using Yealink phones, am I correct? Does this apply to you:

https://issues.freepbx.org/browse/FREEPBX-15238

3 Likes

WHAT?!?!?!? Yes, we are using Yealink phones. We have about 25 sites and over 1000 of them. Okay, let me read though this bug report.

Thank you Lorne Gaetz for your post. The problem listed in the link you provided is exactly what is happening. Upgrading the firmware does resolve the issues; however, since all phones are configured via EPM they are rolled back. We will modify the base config to set the separate SIP server information mentioned in the description edit.

We are using Yealink T46G T46S running firmware 28.81.0.70 and EPM 14.0.2.12.

Again, thank you so much for your reply.

1 Like

You can install custom firmwares through EPM using this method:
https://wiki.freepbx.org/display/FPG/EPM-Admin+User+Guide#EPM-AdminUserGuide-InstallingCustomFirmware

Update the linked ticket with your models please.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.