SNG 7 NTP Server Issue


I have SNG 7 and NTP doesn’t seem to be running. I have all the updates and this hasn’t helped. As a result the time on my phones is out.

I ran this to verify and it does appear to be not running

ntpdate -q

no server suitable for synchronization found

Can anyone assist please?


PBX Firmware:12.7.4-1803-1.sng7
PBX Service Pack:

Go Under Administration > System Admin > Timezone, is it set right?

Note: after making changes you’ll need to reboot your system

All that is fine. The server has the correct time. It is the server that isn’t acting as the NTP server for the phones.


From bash: is the Date/Time correct when you type date and hit enter?

Yes. The date and time is correct. Also seen this from the time conditions page in the FreePBX GUI.


OK, and you sure that your phones don’t have their own time servers? or are off with timezones?..

100%. The command in the original post confirms the NTP isn’t running on the server

ntpdate -q

no server suitable for synchronization found

See this wiki.

Once you’ve done the 4 steps you can go back to the gui and set again the timezone

Isn’t that to to set the PBX server time via an NTP source rather than making the PBX and NTP server?

Running this starts the NTP server service and makes NTP work

systemctl start ntpd

Should I run this to get it to start on server boot?

sudo systemctl enable ntpd


SNG7 doesn’t use ntpd, it uses chronyd for ntp service:

# service chronyd status
Redirecting to /bin/systemctl status chronyd.service
â— chronyd.service - NTP client/server
   Loaded: loaded (/usr/lib/systemd/system/chronyd.service; enabled; vendor preset: enabled)

So how would I fix the problem I have please?

When I run systemctl start ntpd my phones times are correct. How do I use this with chronyd please?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.