FreePBX | Register | Issues | Wiki | Portal | Support

Skip queue when agents are busy / DND


(Leon) #1

Hi,

In Freepbx 14 I’m trying to create a queue with only 1 or 2 agents. When all agents in the queue set the DND, the queue has to be skipped.
I cannot get it to work. Looks like the called as to wait for the queue to finish, even if only one agent is there, set his DND (the hint in the database is show DND is enabled)
Can anyone please help me?

Cheers!


(Lorne Gaetz) #2

Are you tried the various options for ‘Join Empty’? If none of them are working for you you may have to tell your uses to logout from the queue or pause themselves, DND may not be doing the trick.


(Leon) #3

Hi Lorne,

thanks! With the queue pause (*46) this function works fine, however I do not get any State change in the ‘core hints’ in asterisk. It would be nice to assign a DSS key to this function, so users can see the queue pause state.
Any idea?

Cheers


(Lorne Gaetz) #4

There are hints available, program your BLF with:

*46*xxxx

where xxxx is the extension number.


(Leon) #5

Just tried that. Now the BLF stays on (activated or deactivated).
I also do not see any hints changing.


(Leon) #6

Hi Lorne,

any idea? The BLF lamps stays on no matter what the status is (activated or deactivated).
Maybe there is some setting to enable hints for queue states?

Cheers!


(Chris Graber) #7

I have a queue set up with Skip Busy set to yes, Join Empty set to no, and leave empty set to yes. Then I have each person in the queue have a BLF button that will log them in or out of the queue and change colors based on whether they are in the queue or not. This can be done with *45xxx *q where the x’s are the extension number and q is the queue number.
When all agents are logged out the queue is skipped entirely.


(Leon) #8

Hi Lorne,

still no way to visualize the pause state…how can I find the hints?


(Lorne Gaetz) #9

Pause hints have recently undergone fixes, so be sure the queues module is current:
https://issues.freepbx.org/browse/FREEPBX-15350

also if you are running Asterisk 14, that may be an issue:
https://issues.freepbx.org/browse/FREEPBX-15347


(Leon) #10

Hi Lorne,

queue module is at version 14.0.2.6
Also I can see the queue hint from the link is available for the extension:
‘Queue:605_pause_Local/203@from-queue/n’

The V14 bug is not on my system, as the queue pause is working, just the BLF is not working as expected.