SipStation trunks timing out and not registering


(Jack Brisbin) #1

I am running the latest distro after having an issue where my sipstation trunks are not registering.

This is the error i get from the CLI in asterisk

[2019-07-06 18:32:35] NOTICE[29591]: chan_sip.c:15976 sip_reg_timeout: – Registration for ‘7p36NixOaZNq@trunk2.freepbx.com’ timed out, trying again (Attempt #21)

I just did a new clean install of FreePBX Distro on my machine this morning and entered the key for my sipstation trunks and still having the same issue.


(Jared Busch) #2

regenerate your key


(Jack Brisbin) #3

Did that already, about to do it again.


(Jared Busch) #4

That is the limit of my experience with troubleshooting SIP Station trunks.


(Jack Brisbin) #5

still getting the same error in the asterisk cli

[2019-07-06 19:37:54] NOTICE[29591]: chan_sip.c:15976 sip_reg_timeout: – Registration for ‘7p36NixOaZNq@trunk2.freepbx.com’ timed out, trying again (Attempt #2)
[2019-07-06 19:37:54] NOTICE[29591]: chan_sip.c:15976 sip_reg_timeout: – Registration for ‘7p36NixOaZNq@trunk1.freepbx.com’ timed out, trying again (Attempt #2)

Anyone from sipstation in here today?


#6

No response is different from an authentication failure – this sounds more like a networking or firewall issue.

From a shell prompt on the FreePBX machine, can you ping trunk1.freepbx.com and trunk2.freepbx.com? If not, you have a simple DNS resolution or connectivity problem that is unrelated to FreePBX.

Assuming that you can ping ok: Go to Settings -> Asterisk SIP Settings and confirm that External Address and Local Networks are set properly. On the Chan SIP Settings tab, confirm that Bind Port is set properly. If the machine is virtual, confirm Bridged networking and related settings. If using an ISP-supplied gateway, try rebooting that. If behind a NAT, try rebooting the hardware router/firewall.

If no luck, you should try to determine what is going wrong. Useful tools include
sip set debug on
(given at the Asterisk command prompt). This will show any REGISTER requests that Asterisk sends out and any responses it receives. If there are error responses, they may give a clue to the problem. If requests are valid (check that they are going to the correct address/port, as well as the Via and Contact headers) but no response, this is probably a firewall issue.

You can capture packets at FreePBX with tcpdump. This capture is after the software firewall for packets (such as REGISTER) sent out, and before the software firewall for responses received.

If you still have trouble, post details about your system: ISP? Modem make/model? Configured as gateway? Separate router/firewall, if any? Any FreePBX-related settings in modem, router or firewall? If virtual, platform? If FreePBX has more than one NIC, network configuration? Anything else about the network setup we should know about (VLANs, VPN, etc.)?

Also, confirm that the PBX is otherwise ok (calls between extensions work properly, *43 echo test works, etc.)


(Jack Brisbin) #7

Problem was solved. My IP somehow got banned. I put in a support ticket and they were able to resolve the issue in a couple of hours.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.