SIPSTATION module fails on firewall test

Asterisk Ver. 1.8.3 trunks

Contact IP: My Public IP (Static)
Network IP: undefined

ERROR: Your SIP Contact header is a non-private IP address that does not match your network IP. Your system will probably fail typically resulting in one way audio issues. This is usually caused because of an externip setting that is not the same as you WAN IP, or an externhost setting with dynamic DNS information that is not updated. You should check the Asterisk SIP Settings Module or your sip_nat.conf file for the proper settings.

Router settings:

Forward 5060 UDP to (internal IP of FreePBX/Asterisk)
Forward 10000 to 20000 UDP to

Any ideas?

I use the SIP settings module. It is set as:

NAT: Yes
External IP: My static IP
Local networks:

Have only one WAN.

the SIP Settings module uses a similar method of determining the IP address.

bottom line is, what ever the sipstation module shows for your network address is correct and you should change your SIP Settings to that.

The firewall test is a very simple test.

It sends out an http request to a server and the server sends back a UDP looking single packet within the range that is specified in your rtp.conf file.

If you have anything but a simple WAN setup it’s very possible the test could be failing but is incorrect, such as if you have different WANs for voice and data.

As far as the error, it looks like you probably have an incorrect externip or externhost setting, the network address that is being reported is authoritative and the correct address, it is what is seen by the SIP servers. So if you change your settings over in the SIP Settings module to correspond to this it should fix the issue. If you have a dynamic IP address and are using the externhost setting (which is the only ‘correct’ way with dynamic) then your dynamic updating is not being done. If this is the case, you are better to not put anything and allow the private IP addresses in your contact headers which it will warn you about but adjust for accordingly.