SIP working but call ends after 30 seconds

I deployed FreePBX in a docker compose.
Container works fine and SIP extensions links with the devices sucesfully.

When i call between extensions, call is made but finish after 30 seconds because in RTP setings i declare 30 seconds in RTP Timeout.

I tried with devices of different manufacturers and with a softphone, whit the same result.
The local network have been declared in the SIP Configuration.

Any idea?
Thanks and sorry for my bad english.

This is the most common problem that people run into and there are a lot of posts all over the internet and in this forum that tell you what to do.

You’ll need to check Asterisk SIP Settings and make sure that you have the correct values set for External Address and Local Network.

But im in docker. I tried with the IP of docker interfaces, with the network of the base machine (where is docker installed), and with my home network.
None of these has worked.

Same in WAN, tried with my WAN and with the IP of the base machine.

I tried to configure the network that wrote at compose: freepbx_network; not working

version: '3'
    image: tiredofit/freepbx
    restart: always
      - 8085:80
      - 44343:443
      - 5060:5060/udp
      - 5160:5160/udp
      - 10000-10040:10000-10040/udp
       - RTP_START=10000
       - RTP_FINISH=10040
      #- /home/user/freepbx/data/freepbx/etc:/etc/freepbx
      - /home/user/freepbx/data/freepbx/lib_asterisk:/var/lib/asterisk
      - /home/user/freepbx/data/freepbx/spool_asterisk:/var/spool/asterisk
      - /home/user/freepbx/data/freepbx/log:/var/log/asterisk
      - /home/user/freepbx/data/etc:/data/etc
      - /home/user/freepbx/data/home:/data/home
      - /home/user/freepbx/data/var:/data/var

    driver: bridge

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.