Sangoma Completes Acquisition of Digium: Sangoma Press Release. Community FAQ: Sangoma and Digium Join Together FAQ
FreePBX | Register | Issues | Wiki | Portal | Support

Sip Trunk register setting


(Kingsley School) #1

Hi everyone,
I have a sip provider, we have the trunks registered and calls and flowing most of the time.
inbound calls fail multiple times each day.
The sip provider tells us that we need to edit the sip.conf file. But we all know that we should not do that with freepbx.
the issue they see is an “s” comming from us.
Contact: sip:s@136.228.37.90:5060;line=rwbxcjl

they want us to add this line to the trunk config to fix that issue.
Register=2313464000:{PASSWORD}@72.255.120.75 /2313464000


#2

You can add that in the “register string” box on the user tab of the trunk config.


(Kingsley School) #3

I don’t see the anything like “register string” in the trunk config area.
these are pjsip trunks if that means anything to you guys.


(Lorne Gaetz) #4

Looks like you need to set the “Contact User” for the pjsip trunk.


#5

Sorry, I was thinking about CHAN_SIP trunks.
I currently use chan_sip for trunks as the providers I deal with don’t seem to support pjsip and won’t provide any help unless the trunk is chan_sip.
If you are willing to try, disable the pjsip trunk so you don’t have to delete it and create a chan_sip trunk so you can use the register string.
I’m sure that pjsip also has that option, but it might have another name, which I’m not familiar with.


(Kingsley School) #7

We are still working with the provider. We will most like switch the trunks to sip-chan.
I tried the “Contact User” field. it don’t help.

Thanks for the help.