SIP Trunk (poivy) timing out /disconecting

I have a TrixBox v2.8.0.4, with a POIVY trunk. this setup was working fine for a month with no issues! now since last week my trunk disconnects and does not connect until I either reload the setting or restart the server. some times the trunk does connect back itself but after a long time.
at the beginning this setup was working fine for me, but since a week i have this issue! strangely i have made no changes what so every to my box.

this is my peer details for the trunk:
register string:
username:[email protected]

these are the settings under my sip_general_custom.conf file:


any idea what is going wrong!

i just noticed the following in the logs when the POIVY trunk manages register:
[May 21 19:24:45] NOTICE[2785] chan_sip.c: Peer ‘POIVY USER’ is now Reachable. (1043ms / 2000ms)

This is what i get when it doesn’t register:
[May 21 19:15:49] NOTICE[2785] chan_sip.c: – Registration for ‘POIVY USER’ timed out, trying again (Attempt #123)

notice the very high delay (1043ms / 2000ms)! could this be the reason the trunk does not register other times?

is there any relation between the delay time of trunk and values set in Sip_general_custom.conf file?

hope some one can help

  1. Trixbox is OLD. You might consider a newer version, i.e. FreePBX Distro or PBX In A Flash.
  2. Try another provider.

The route from your home to POIVY’s server is not reliable. This is a common problem, and there’s nothing you can do about it. I run several FreePBX installs in Orange County that have terrible problems routing to VOIP.MS in Los Angeles (35 miles away), but great routing to Seattle (950 miles away) and to Callcentric’s servers in New York (2,200 miles away).

i have already installed PIAF, but couldnt manage to even register my POIVY trunk on it as i did on TrixBox. with exact same setting! i tried to get help to fix this but no one replied, i also tried to sign-up to PIAF forum (multiple times), but after filling out all the info for registration it would say that admin must accept my request, this acceptance never came! i also sent them emails with no luck. it seems they are just not interested in new users!

i understand your point about the reliable path. but it is strange to me that POIVY works perfectly on my PC, in the same network. it also registers every time i ‘reload configuration changes’ on TrixBox! later attempts seem to fail!

As Asterisk has progressed from 1.4, to 1.6, and now to 1.8, Digium has changed a number of the trunk settings parameters. As a result, the settings that worked in Trixbox may not work on FreePBX. You’ll need to ask POIVY for the proper settings to get things working in Asterisk 1.8.

See my comment #2, above. Try another provider.