SIP trunk now failing to register

freepbx
Tags: #<Tag:0x00007f4f43dc12b8>

(Awl Mike) #1

Hi All,
I have an issue with a SIP trunk connecting and registering. The trunk has been working for weeks with no issues.

I initially looked into the issue and stopped and restarted the Intrusion Detection service and it seemed to clear the issue. This was a coincidence I believe now as the trunk is still not registering.
This is what i have tried:

1.contacted the SIP trunk provided and they have checked their settings are correct and the trunk is online. They have connected a test setup and its working.
2.Im able to ping the SIP host from the PBX VM.
3.Under SIP settings (chan_sip) I have changed from static to public IP to test.
4. Changed NAT to yes and never to test.
5. put the PBX in a DMZ (so no firewall)

Outgoing Trunk SIP Settings:
username=(myusername)
type=peer
secret=***************
registertimeout=600
qualify=yes
port=5060
nat=yes
keepalive=30
insecure=port,invite
host=93.95.124.102
fromdomain=sip40.voiceflex.com
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=alaw&ulaw&G729&GSM&G726

Nothing has changed and no updates have been done the trunk has just started to fail to register with no reason.

I think can see its using port 5160 to register but its set for 5060 so im confused. The provider needs me to use port 5060.

Some guidance would be greatly appreciated.


(Awl Mike) #2

Debug Log:


#3

Confirm that the VM is using bridged networking (the PBX local address is in the same subnet as the host).

Static IP is the correct setting. Leave Override External IP blank.
Under General SIP Settings, confirm that External Address and Local Networks are correctly set.
Visit https://www.whatismyip.com/ to be sure that your public IP matches what is in External Address.
If you change this, you must restart Asterisk.

Not a good idea. Depending on your router/firewall, you many need to forward UDP port 5160 to the PBX.

Your issue might be a corrupted NAT association. If you haven’t already done so, try rebooting your modem and router/firewall.

Asterisk is seeing no reply to its REGISTER requests. Run sngrep, wait until a REGISTER request appears and see whether any replies are received. If so, FreePBX Firewall is blocking the replies; test by turning it off. If that allows registration, set the provider’s address as Trusted and also whitelist it in Intrusion Detection.

If you still have trouble, post details: ISP? Modem make/model? Separate router/firewall? Any VoIP-related settings?


(system) closed #4

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.