SIP trunk not routing to destinantion

Hi there I need someone with serious freepbx kung fu skills, we have a Net2Phone sip trunk on a Elastix pbx but the incoming and outgoing are not going where they are supposed to:

we had a working SIP trunk but we had to get a new account, same number, same provider, after we changed the account info it doesn’t work not the incoming nor the outgoing are working but the
SIP account is registering fine. I have specified a incoming call route, the destination is an extension (407). I’ve also tried a group as the destination but still nothing. I also have the dial pattern which uses the outbound route. Dialing out isn’t working either.
elastix-2.2.0-14
freePBX-2.8.1-7

Verbosity is at least 5
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5

Executing [1305XXXXXXX@from-sip-external:1]
NoOp(“SIP/206.20.196.19:5060-00020dfa”, “Received incoming SIP
connection from unknown peer to 1305XXXXXXX”) in new stack
– Executing [1305XXXXXXX@from-sip-external:2] Set(“SIP/206.20.196.19:5060-00020dfa”, “DID=1305XXXXXXX”) in new stack
– Executing [1305XXXXXXX@from-sip-external:3] Goto(“SIP/206.20.196.19:5060-00020dfa”, “s,1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [s@from-sip-external:1] GotoIf(“SIP/206.20.196.19:5060-00020dfa”, “0?checklang:noanonymous”) in new stack
– Goto (from-sip-external,s,5)
– Executing [s@from-sip-external:5] Set(“SIP/206.20.196.19:5060-00020dfa”, “TIMEOUT(absolute)=15”) in new stack
Channel will hangup at 2015-11-09 10:20:36.705 SRT.
– Executing [s@from-sip-external:6] Answer(“SIP/206.20.196.19:5060-00020dfa”, “”) in new stack
– Executing [s@from-sip-external:7] Wait(“SIP/206.20.196.19:5060-00020dfa”, “2”) in new stack
– Executing [s@from-sip-external:8] Playback(“SIP/206.20.196.19:5060-00020dfa”, “ss-noservice”) in new stack
– <SIP/206.20.196.19:5060-00020dfa> Playing ‘ss-noservice.gsm’ (language ‘en’)
– Executing [s@from-sip-external:9] PlayTones(“SIP/206.20.196.19:5060-00020dfa”, “congestion”) in new stack
– Executing [s@from-sip-external:10] Congestion(“SIP/206.20.196.19:5060-00020dfa”, “5”) in new stack
== Spawn extension (from-sip-external, s, 10) exited non-zero on ‘SIP/206.20.196.19:5060-00020dfa’
– Executing [h@from-sip-external:1] Hangup(“SIP/206.20.196.19:5060-00020dfa”, “”) in new stack
== Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/206.20.196.19:5060-00020dfa’

Fixed it had to do with the user context which wasn’t mentioned clearly in the documentation