SIP trunk my problem or sip provider?

I have been trying to setup a sip trunk for about a week now. I have it connected and called both in and out are connecting.

However I have no voice in or out for mostly everything. Right now the setup is one Free PBX box with two nics one nic plugged straight into their network. The other nic on the box is connected to my internal network. The weird thing is the voice traffic was working on a PRI that the same company was providing. However anything off their network voice was not working period. So my question is, is this something wrong with my stuff or theirs? Can anyone give me some advice on how to fix either my stuff or theirs?

Thanks

After doing some troubleshooting with the system. eth0 is the nic connected to my sip providers network. eth1 is connected to our network. When I type the command ifup eth0. The freepbx server becomes unreachable via the network. However the phones are still able to connect and call out. When calling out now I have voice and everything works perfectly with calls. Can anyone suggest away to fix this?

Check your route table, your probably configured two gateways.

Do you understand how IP routing works when you have multiple connected interfaces?

I actually don’t know how it works with two nics, this is my first time ever trying this. But your right I do have two gateways. The top line is the static route that I added which when added allows me to connect to the sip trunk and make calls. But voice traffic does not work. Any guidance would be apperciated as always.
Destination Gateway Genmask Flags Metric Ref Use Iface
10.10.10.21 10.40.50.1 255.255.255.255 UGH 0 0 0 eth0
10.10.7.0 * 255.255.255.0 U 0 0 0 eth1
10.40.50.0 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 1002 0 0 eth0
link-local * 255.255.0.0 U 1003 0 0 eth1
default 10.10.7.254 0.0.0.0 UG 0 0 0 eth1

ip address, mac address, netmask, gateway, then configure eth1 with everything except for a gateway address (you can set it to 0.0.0.0). then add a route (google ip route add). the syntax is something like ip route add 192.168.10.0/24 via 192.168.10.1 dev eth1. restart your network. make sure the local network is listed as a local net in sip.conf (sip settings).