SIP trunk keeps disconnecting

Hi,

Using FreePBX 12.0.76.2

Some users are reporting to be unable to make calls.

They here a “all lines are busy” message.

In the CLI it gives me this:

[2015-11-12 16:03:49] WARNING[11093][C-00000017]: chan_sip.c:23159 handle_response_invite: Received response: “Forbidden” from ‘“XXX” sip:[email protected];tag=as1d9ca74b’

Where XXX is just to take out prive info

So is this “Forbidden” response coming from FreePBX or is it from the SIP provider.

Thanks!

UPDATE : I can see the SIP trunk keeps disconnecting.

How can I see the log, or get any kind of information, in order to provide to the SIP provider, so we can fix the problem ASAP ?

Thanks !

Bonjour! (Hi!)

It would have been useful to see the information your removed from your first post…

That’s what is telling you who is refusing the communication…

Since you removed it we cannot really say…

Bonne chance et bonne journée! (Good luck and have a nice day!)

Nick

Bonjour! (Hi!)

If it is their servers which are refusing the communication they don’t need your logs, they can debug on their side…

However, if you want to see what is happening remote your server and issue:

asterisk -rvvvvvvvvvvvvvv

and then activate the sip trace with

sip set debug on

Bonne chance et bonne journée! (Good luck and have a nice day!)

Nick

Well well well

They pointed me to this:

https://doc.pfsense.org/index.php/VoIP_Configuration

And what I noted is this:

A keep-alive or re-registration on the phone set for 20-30 seconds or so can also help, and is often a better solution.

So I tried to add these settings to my trunk:

qualify=yes
qualifyfreq=20
keepalive=20

But looking at the sip debug in CLI, I still get:

Expiry for XXX is 120 sec (Scheduling reregistration in 105 s) 

How can I make it so everything is set up so Asterisk checks the connection every 20 seconds?

that’s a normal message for registration – As long as you get that message about every 105 seconds, you should be fine.