SIP registration via VPN


I have been playing around with a Sangoma S405 and FreePBX 14. I have successfully got the phone connected by VPN, however, like the user in the following post:

the only way I can get the phone to register with the PBX is by logging in to the phone’s web GUI and under “Account”, changing the “Connect mode” from “Local” to “VPN”. After I save that setting, the phone registers within a minute or so and works perfectly fine. The forum post above though indicates that after enabling VPN for an extension in VPN, nothing else needs to be done. I am assuming that the way you enable VPN for an extension in EPM is by assigning it a VPN certificate in its EPM config? There isn’t anything else you have to do? I have reviewed the VPN docs on the Sangoma site and I am pretty sure I have done everything that is in them.

In my template that the extension is assigned, I have the Provision Server address set to the external address and the “SIP Destination” address set to the Internal address of my PBX. Is this correct?

OK, so I connected my phone to a FreePBX 13 system in our colo and it worked exactly as advertised; I didn’t have to manually enable the “VPN” Connect Mode as it got done automatically.

That being said, after some testing it doesn’t look like we will be using the VPN functionality afterall. I made three test calls of a anywhere from 2-5 minutes each and they started out fine, apparently, but then the other party would tell me I was starting to sound choppy. The party was talking to sounded just fine.

I then connected my phone to the PBX without VPN (i.e., via “normal” method of registering via port UDP/5060) and I made three more test calls, each 2-5 minutes long again (to the same party I was talking to earlier). There was no choppiness at all.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.