Sip registration lost


(Ralph) #1

I have a problem which has references elsewhere. My system is 15.0.16.73 and about once a week the sip registration ceases. I saw a post which related to this and advised Advanced settings change nothing and submit and then config. This works and registration with my sip provider starts again.
My question is what is going on and can it be corrected?
Many thanks
Ralph Graham


(Reinhard Stindl) #2

Do you use sip or pjsip trunks? Sometimes it is tricky to find the correct settings for your provider…especially with pjsip. I returned to sip, because my pjsip trunk went offline every month or so.


(Ralph) #3

Thanks for reply. I use sip and have had no problems until after update about 3 weeks ago. This maybe something that came in with updates in early August.


(Reinhard Stindl) #4

I use sip-trunks on 4 freePBX systems and havent seen any trunks, which went offline. I applied all updates. It could well be that your sip trunk settings aren’t perfect, but worked with previous versions. I am just guessing…I am no pro, just a user like you.

EDIT:
here are my settings (outgoing, trunk), just as an example:

username=yourusername
type=friend
secret=xxx
qualify=yes
port=5160
nat=yes
keepalive=500
insecure=port,invite
host=trunk.xxxxx.at
fromuser=yourusername
fromdomain=trunk.xxxxx.at
disallow=all
context=from-trunk-sip-yourtrunkname-in
allow=g722,alaw


(Ralph) #5

Possibly but the odd thing is when I resubmit Advanced settings and config I have changed nothing in the settings at all. If I have an error I would think resubmitting the same settings would continue the the problem but it does not.
Thanks for your thoughts.


(Reinhard Stindl) #6

When the trunk goes offline, a restart always reconnects…same thing happened to me when I had the problem with a pjsip trunk. Maybe the keepalive value will help in your case (sip trunk, see above)? If a trunk loses the connection it should always automatically reconnect…in your case it doesnt do it…so maybe you should play around with the keepalive value…


(Ralph) #7

My sip settings came from my provider, I have added a keepalive which was not there before.
Will await any problems in the future.
Thanks again.


(Reinhard Stindl) #8

some providers do not like keepalive some do. you’ll find out. I just played around with my settings and stopped once the trunks were absolutely stable.


(system) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.