SIP - No Audio on voicemail from inbound calls, phones work fine, calles transferred to voicemail work too

I have a new FreePBX install

AASTRA phone
FreePBX installed from distro downloaded last week
Flowroute SIP Trunk with DID
3Com OfficeConnect VPN Firewall
Public static IP address

Firewall has had various ports forwarded in troubleshooting ranging from just SIP ports (10000-20000, 5060) and in testing, everything wide open.

Outbound calls = fine
Inbound calls to phone = fine
Inbound calls to phone transferred to voicemail = fine
Inbound calls to voicemail directly (DND or Ring No Answer) - voicemail audio is not there. A 0 second message is recorded, no audio on either side.

Issue appears to be - SIP is not “connecting” to the freePBX voicemail, but SIP is connecting to phones, and when phones transfer the call back to freePBX to handle voicemail - connection occurs.

In various testing (changing IP addresses, re-registering SIP connection with FlowRoute, etc) - I got it to work for a few minutes.

I think the 3Com firewall might be to blame, although all ports are open at this point.

System worked on a residential DSL just fine in initial testing, with dynamic IP addresses with the freePBX configured for the public ip address of the DSL modem.

I found this issue unanswered in a few other forum posts. This post closely resembles my problem (had to add spaces since links are not allowed by new users):

community dot freepbx dot org/t/voicemail-audio-issue/13827

status update, took the computer and phone to my house, changed my DSL DHCP to the same address block as the office, and changed the out side IP address in FreePBX, and it works flawlessly. so the only 2 differences are the 3 com officeconnect firewall, and the internet service provider itself.

I had every single port open on the firewall at the office, it is still blocking the traffic, any ideas why?

Our phone system uses multiple SIP trunk providers and we had a similar problem with our Flowroute trunk recently. By changing the trunk PEER details to match one of our other trunk configurations we were able to resolve issue with voicemail not recording. It appears likely that the line “rfc2833compensate=yes” was most likely the solution, but here is a full listing of the PEER details used (with login information redacted).


These settings worked to establish a connection to Flowroute but are different then those provided by Flowroute.