sip_nat.conf problem

I am running version 5.211.65-11 and system has been up and working for a few months. When setting up a VPN for testing remote phone capability (pfsense openVPN instance), I had to add the tunnel network to the sip_nat.conf so I edited this file manually and everything worked fine. This was several months ago and I can’t quite remember if sip_nat.conf was empty at the time (i.e. if I had to all all the entries in the file or just add the local net entries).

When I recently entered the sip settings module within the FreePBX GUI, it displayed a message:

“Settings in /etc/asterisk/sip_nat.conf may override these. Those settings should be removed”.

However, removing the manual localnet entries in the file does not remove the message. I tried renaming sip_nat.conf, restarting FreePBX, and another sip_nat.conf was created. This resolves the error message in the sip settings module but when I add the entries I need through the module and apply settings, nothing appears to be written to the file when I check it manually (it remains blank). Is this normal behaviour? I checked the permissions on the file and they are correct.

When FreePBX is working properly and all sip_nat settings were entered into the sip settings module, would it be normal for the sip_nat.conf file to be empty?


gurus, disregard the question above (resolved). For anyone else that finds this via search, FreePBX actually stores the settings from the Asterisk SIP Settings module in /etc/asterisk/sip_general_additional.conf. That file should not be edited manually (as per the giant warning at the top of the file).