SIP IP trunk not registering

I have 1 Trunk (SIP).
freePBX displays:
IP Trunks Online: 1
IP Trunk Registrations:0

I’m new to this and drawing a blank on how to get the trunk to register or how to investigate it further.

Any advice appreciated



I’m setting up a new asterisk Now installation (FreePBX, Asterisk 1.8.11-cert1). The installation is for test and experimentation purposes for now, on a old PC, with router to cable internet connection.

Trunk Set up (Password obfuscated), set up based on
Using FreePBX I’ve configured the following:
Trunk Name: draytel
Outbound CallerID: 01463896390
CID Options: Allow Any

Outbound Settings:
Trunk Name: draytel
PEER Details

Registration String: 8483671:[email protected]/8483671
I’ve also tried this as: 8483671:[email protected]/01463896390

Inbound route set up But I assume thats not relivant

Network Set Up/NAT set up

The Draytek router uses dyndns to update my dyndns hosted domain. The name is resolving to the correct IP.

I’ve the following ports forwarded on the router to the PC’s Static IP:
TCP and UDP 4560-4570
TCP and UDP 5000-6000
UDP 10000-20000

/etc/asterisk/sip_nat.conf edited manually to include (Host name obfuscated):
localnet =

dns names resolve (e.g. ping successfully)

Don’t edit sip_nat.conf.

Remote those settings and use the SIP settings module.

You should also not have to open SIP up to the Internet.

Not sure where you got that port range. Only need 5060, you also should lower the RTP range in RTP.conf to something less than 10,000 ports.

Your trunk config makes no sense, first you supply authentication credentials then you use the insecure directive to tell Asterisk to ignore authentication for this host.

Many thanks.

Just the direction I needed. several fustrated hours of getting no-where and 2 minutes to sort when I knew what to look for (didn’t even know the sip-settings modules existed to install it)



I read through this issue, and it sounds very similar to mine. So I have my SIP trunk connecting as a peer, and it works fine for outbound calls. my ISP that is supplying me with the SIP trunk “doesn’t support” FreePBX, but did share some information that they found worked when they helped another client. They did a packet capture to see if any packets are getting there from my IP on that port, and they see nothing. I set the same account details in an Yealink phone, which works. I set it up on X-lite, and it works. When I look at the SIP Registraions, I see 0 SIP Registraions. It is like it never triggers the registration process. I have used the registration string that they provided me. Again, the same account information works from the same LAN out to them (using the softphone and the hardware IP phone), but the FreePBX won’t attempt to register. Any direction would be helpful. Again it does sounds very similar to this issues, but I’m not reading what Tartan75 actually found as the solution.

Jim, start another thread. Doubt it is same issue and you need to post all your info to get help.

Make sure you include redacted settings that work from x-lite