Sip FROM & CONACT headers

Hey guys. having a weird problem with Long distance calls. to start the truck is working with US calls but when i call London the call doesn’t go through. i look throught out may setting and didn’t see anything wrong and the wiki for Voip.MS for Freepbx but everything is right as well. so i contacted them. and this is would they told me.
There’s 2 important & outstanding details in the FROM & CONACT headers, allow me to explain
You’re sending them as:
From: <[sip:PHONE [email protected] IP]>
Contact: <sip:[email protected] IP:5060>
So basically you’re sending the callerID where the SIP UserID should be and your public IPv4 where our POP server should be in the From header and “asterisk” where also the SIP UserID should be in the Contact header, Thus, they should look like:

From: <[sip:Account [email protected]](mailto:sip:Account [email protected])>
Contact: <Account [email protected] IP:5060>
In order for the invites to be authorized & digested properly in our end

So my question is where do you even make those changes and if its was wrong why do it work with US call?

thank you guys.

The provider is wrong. The user part is optional an its value is opaque. Anything other than Asterisk that tries to take any meaning from the user part is buggy. However there are some options for dealing with this brokeneness, in Asterisk:

I’m fairly sure there is a GUI option for this, although the online user guide is out of date. It might be in the advanced settings.

Unless using Tel: URIs, which Asterisk cannot source, the caller ID is sent as a SIP user field. Strictly speaking the whole SIP URI is the equivalent of a caller ID, but most people use SIP to emulate legacy phone networks, and ignore the domain part. From headers can be used to indicate the entity that authorised the call to go to the provider, particularly when using registration rather than IP based authentication, so there is an Asterisk option for this, see the same document as above, where it is called from_user.

Again I believe there is a GUI option for this, in current versions, however people often just manipulate the caller ID.

If you do force the From user and still want to send the identity of the call originator, you will have to enable other means of doing that, such as P-Asserted-Idenity or Remote-Party-ID. I believe the options for doing this, with chan_pjsip are in the Advanced Trunk Settiings.

If you don’t care about calller ID, you can also set the caller ID to the account code, in the outbound route.

Thank you. @david55 that somewhat i was thinking. if this was wrong then calls wouldn’t go out at all. but the problem only seem to be Long Distance. but i want to check that before going in their changes stuff that don’t need to be changed.

Before getting too involved with calling UK on, see

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.