Sip extensions stop to ring after 2 minutes

Hi to all.
I have this strange problem with my sip extension on freepbx 2.7 + asterisk 1.4.30.
When I call a sip extension it ring for 2 minutes exactly then it hang up.
I receive the busy on the sip channel.

This is the shell message when that happened(ext203 has called ext201):

– SIP/201-00000061 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)
– Executing [[email protected]:8] Set(“SIP/203-00000060”, “DIALSTATUS=CONGESTION”) in new stack
– Executing [[email protected]:9] GosubIf(“SIP/203-00000060”, “0?CONGESTION|1”) in new stack
– Executing [[email protected]-exten-vm:10] GotoIf(“SIP/203-00000060”, “0?exit|return”) in new stack
– Executing [[email protected]:11] Set(“SIP/203-00000060”, “SV_DIALSTATUS=CONGESTION”) in new stack
– Executing [[email protected]:12] GosubIf(“SIP/203-00000060”, “0?docfu|1”) in new stack
– Executing [[email protected]:13] GosubIf(“SIP/203-00000060”, “0?docfb|1”) in new stack
– Executing [[email protected]:14] Set(“SIP/203-00000060”, “DIALSTATUS=CONGESTION”) in new stack
– Executing [[email protected]:15] NoOp(“SIP/203-00000060”, “Voicemail is novm”) in new stack
– Executing [[email protected]:16] GotoIf(“SIP/203-00000060”, “1?s-CONGESTION|1”) in new stack
– Goto (macro-exten-vm,s-CONGESTION,1)
– Executing [[email protected]:1] NoOp(“SIP/203-00000060”, "IVR_RETVM: IVR_CONTEXT: ") in new stack
– Executing [[email protected]:2] GotoIf(“SIP/203-00000060”, “0?exit|1”) in new stack
– Executing [[email protected]:3] PlayTones(“SIP/203-00000060”, “congestion”) in new stack
– Executing [[email protected]:4] Congestion(“SIP/203-00000060”, “10”) in new stack
== Spawn extension (macro-exten-vm, s-CONGESTION, 4) exited non-zero on ‘SIP/203-00000060’ in macro ‘exten-vm’
== Spawn extension (from-internal, 201, 1) exited non-zero on ‘SIP/203-00000060’
– Executing [[email protected]:1] Macro(“SIP/203-00000060”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/203-00000060”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“SIP/203-00000060”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“SIP/203-00000060”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“SIP/203-00000060”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/203-00000060’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/203-00000060’

I can’t understand if this is a freepbx problem or a phone settings problem.
I have this issue with a snom 300.

I tryed to change the phone type and the issue is always the same but with different times.
For example with a siemens ip cordless A580 the phone ring for 3 minutes,with a Linksys ATA PAP2T the phone on the fxs port ring for 1 minutes.
The shell message is always the same “circuit-busy”.
No follow me or voicemail are enabled.

I can’t get it what could that be?

I find it!
It is a phone setting.
You can find the value in the snom phone configuration file.

This is the row:
ringing_time!: 120

The default value is 120 seconds(2 minutes) but you can increase that.

Bye!