Sip calls/channels randomly get stuck

Not sure if this is the right place to ask the question but I will try anyways.
I have been able to replicate a problem with my SIP calls. The problem is that sometimes the calls will not terminate when put on hold or disconnect. After the Phone calls disconnect, the channels remain active and are still connected. I have been here and read similar things that were related to my own issue. I was just wondering if this problem has been resolved in any beta builds etc. I have tried rtptimeout settings, tried all sorts of things actually. Im running a Pfsense firewall and I know my NAT is running just fine in this case. Just wondering if you guys had any updates on this on going problem as of lately.

Thanks guys :-).

Just found out its doing it to Music On Hold, and Music on Hold forever as well. The channels stay open indefinitely randomly. I wonder what either I’m doing wrong or if there is a setting I’m currently missing. Hmmm

What version of Asterisk? Are the phones local or remote? What is the network architecture? This is a network not an Asterisk issue.

Stable-1.1007.210.58 Asterisk version 10.7.0. The phones are local and remote going to Site to Site through our OpenVPN tunnel. Its a simple network layout going from Optic fibre 20mbit relay to a Pfsense router to a 24port gigabit switch.Same goes for the other site on the opposite side of the OpenVPN tunnel. All ports are forwarded correctly and no packet loss. The phones work great with no quality loss. Same goes for soft phones. If one of someone is on a softphone, ip-phone or ata the call stays open and doesn’t shut down when it hits hold music. The only way to end the call I found was to restart the amportal or reboot the server altogether. We can also reproduce this randomly. For example, if someone is put on hold, the caller decides to hangup the BYE command is not issued. The call is stuck with the music still playing and will not time out. It seems to only do it with music on hold or Forever on hold. rtptimeout will not function correctly. I setup a test system with blocking telemarketers, and it does the same for them as well. When the telemarketer call comes in, it puts them on hold forever as the destination (tried with regular hold music too). Then the call stays open without timeout after they hangup. Is there any way to issue a timeout after a certain period of time for the hold music/forever on hold settings specifically? That should fix the issue I’m having. Unless rtptimeout is for that as well.

You are running FreePBX with Asterisk 10? I was not aware of this working outside of a lab.

Thats what it says when I do a core show help in the asterisk cli
"Asterisk 10.7.0 built by root @ on a i686 running Linux on 2012-08-13 20:07:09 UTC"

[2012-09-14 23:50:59] VERBOSE[20374] pbx.c: == Spawn extension (app-blackhole, musiconhold, 3) exited non-zero on 'SIP/VoipGo-00000021’
So strange, it took over an hour but it corrected itself. It ignores the rtptimeout and has its own for timing out with hold music I think. Not to sure, but it seems to be solving itself. Just takes a very very long time. Wonder if there is a way to shorten it. Even 15-20 minutes would be fine for me.

You know you are running early beta code? You should always run stable releases unless you are testing a feature. It is kind of scary you are running the beta release on a 80 phone deployment.

What version would you suggest I run for FreePBX? I went with the Stable-1.1007.210.58 Release Date-08/14/12 32bit before Back to 1.817.210.58 would you suggest? Didn’t think it was Beta since it says Stable in the name mate. Let me know what you think.

correction Back to 1.815.210.58 would you suggest?

Ok im taking a break, ment to put 815 lol. 2am is my limit.