sip_additional.conf not working properly

I am using Certified asterisk 11.2, freepbx 2.11 and Xlite as soft phone.

My sip_additional.conf is like:

[1001]
deny=0.0.0.0/0.0.0.0
secret=asd123
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=udp
encryption=no
callgroup=
pickupgroup=
dial=SIP/1001
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=1001 <1001>
callcounter=yes
faxdetect=no

And when i used following details for registering Xlite.

Display name:1001
Username:1001
Password:asd123
Domain:192.168.1.75

And I set ‘Send outbond via’ as ‘domain’.

And while registering with Xlite i am getting an error “Registration Error 403. Forbidden”.

And in asterisk server CLI I fouund an error like " NOTICE[2361]: chan_sip.c:27749 handle_request_register: Registration from ‘“1001”’ failed for ‘192.168.1.25:10512’ - Wrong password"

My asterisk server is installed on Centos 6.4, and centos is running in VMware.

Can you please find a solution?

Finally found the answer. I forget to add extension.conf details :slight_smile:

I’m in the same shoes you are, with similar setup. I’m also new to PBXs. What do you mean by adding extension.conf details?

Thanks for your help.

Are you hand editing the .conf files? You really should be adding extensions through the GUI. The *_additional.conf files and the extension.conf will be overwritten anytime you edit parameters from the GUI and/or do a version update.

BF

I am a hand at editing conf files, but I am using the GUI, so I should do it from there. I did get a X-lite phone going with these parameters:
User ID: userid
Domain: 192.168.10.106
Password: password
Display name: userid
Authorization name: userid
Proxy 192.168.10.106
The userid is the extension name given in Freepbx
However, I am not able to get csipphone going on my phone with another user id with the same settings. My question: Does every extension need a unique port number? If I use another port number, how do I get Freepbx to listen? I suspect that this may be the problem.

No every extension does not need a unique port number. They all connect to the same port (5060 by default) for signaling.

I set the port back to 5060, and now I get the error message on the phone - 'Error when registering - forbidden. The sip set debug ip 192.168.10.104 on the Freepbx box says "registration from Jmm <sip:ip 192.168.10.106> failed for ‘192.168.10.104:35811’ - Wrong password.
Two strange things - Jmm is not the username I am using on the phone, and the password is not wrong.
Thanks.
James

I installed csipsimple on another phone, created another account in Freepbx, changing only the display name and the password. I get the same error message as the first phone. I tried the account that works with the x-lite phone, and it acts the same way. There must be a setting n the phone that prevents it from working. Any ideas?
James

Is there no one doing this - using Free pbx and a Android softphone? What settings are you using on the phone? I would appreciate help.

Thanks.

james

OK I set the CSipPhone settings to local, and gave the account name, and it registered. I now have 2 Androids and a X-Lite soft phone registered. I would like to be able to talk between the extensions, but I get the error 502/ gethostbyname() has returned error (PJ_ERESOLVE) error. I know this is likely DNS, but I do have the DNS set right, I feel. And anyhow, how can the DNS help between local phones?

James

Any ideas?

What user name are you using in your SIP Client?

Jmm which is the extension name in Freepbx

I feel stupid to write this but it may help other newbies get started. I used the display name as the user instead of the extension number. He are the things that need to be:
1.- server IP addresses need to be right
2.- Asterisk IP settings need to be right
3.- extension needs to be created with a password - the extension name - not the display name - is important
4.- allow and deny lists to be 0.0.0.0/0.0.0.0 (at least to get started)

James

Wow, you went through all this and that is what it was?

Why I always recommend, people of all levels read the getting started guide in the wiki.

That’s right. It’s usually something very small that throws a monkey wrench in. I found an excellect documantation on the Arterisk website that helped me see the problem. It was a PDF, and I downloaded it. Now in the coming days as I tweak Freepbx to do what I want, it will be useful. Has about 700 pages!

nbstk13:

What do you mean by “forgot to add extension.conf details”? I’m having the same problem. Can you be more specific about how you solved the problem?